[sane-devel] Epson DX7000F

Olaf Meeuwissen olaf.meeuwissen at avasys.jp
Thu Nov 1 00:11:20 UTC 2007

Massimiliano Ciancio <mciancio at tiscali.it> writes:

> Hi all,
> I'm using a new all-in-one Epson DX7000F 
> The scanner device data are the following:
> ------------
> # lsusb
> Bus 003 Device 003: ID 04b8:0831 Seiko Epson Corp.
> # sane-find-scanner
> found USB scanner (vendor=0x04b8 [Language Error], product=0x0831
> [Language Error]) at libusb:003:003
> # scanimage -L
> No scanners were identified. etc etc....
> # iscan
> "Could not send command to scanner. Check the scanner status"

The DX7000F is _not_ supported by iscan.

> ------------
> I tried to:
> - insert usb 0x04b8 0x0831 into epson.conf / epson2.conf / epkowa.conf
> - install libsane-extras
> - download, compile and install iscan from avasys
> - insert usb 0x04b8 0x0831 into snapscan.conf: the scanner starts but
> it's all in black&green /this tip is in iscan/doc/epkowa.desc)
> - write to avasys msg board (til no reply...)
> - use scanner under a virtualized (VirtualBox) XP machine
> none of this worked.
> What can I try?
> Do you think that I've some hope now or in the future for the
> inclusion of this scanner in the eposn-backend?

In the epson backend?  No hope.
In the snapscan backend?  Who knows.
In the epkowa backend (part of iscan)?  Maybe, but I doubt it.

> Do you know if the avasys development is still alive?

Yes, still very much alive.  I've just added support for a big batch
of all-in-one devices, slated for release Real Soon Now.

> Thanks in advance 

You're welcome.
Olaf Meeuwissen             FLOSS Engineer -- EPSON AVASYS Corporation
FSF Associate Member #1962           sign up at http://member.fsf.org/
GnuPG key: 6BE37D90/AB6B 0D1F 99E7 1BF5 EB97  976A 16C7 F27D 6BE3 7D90
Penguin's lib!       -- I hack, therefore I am --               LPIC-2

More information about the sane-devel mailing list