[sane-devel] SANE does not recognize my Epson CX-3900 anymore

Olaf Meeuwissen olaf.meeuwissen at avasys.jp
Thu Aug 21 01:02:39 UTC 2008

Kanito 73 <kanito73 at hotmail.com> writes:

> Hi friends
> I've just reinstalled my system and can't make work SANE again with
> my Epson CX-3900
> My scanner is 100% supported and was running on Slackware 12 (now
> 12.1), all installation procedure for MY scanner was stored in a
> text file so I don't forget it (have reinstalled it several times
> before)...

Disclaimer: not familiar with Slackware.

> First installed backend (x.19), then frontends (x.14?) and finally
> xsane 0.995, it is installed as usual at /usr/local, the
> configuration I use always is this:

All of the above lives in /usr/local?  Any SANE bits living somewhere
else on your system, like say in /usr/lib/sane/ or /etc/sane.d/?

> /usr/local/etc/sane.d/epson.conf:
> # SCSI scanner:
> # *** all scsi was commented ***
> #
> # USB scanner:
> # There are two different methods of configuring a USB scanner: libusb and the kernel module
> # For any system with libusb support (which is pretty much any recent Linux distribution) the
> # following line is sufficient. This however assumes that the connected scanner (or to be more
> # accurate, it's device ID) is known to the backend.
> usb
> # For libusb support for unknown scanners use the following command
> # usb <product ID> <device ID>
> #####found USB scanner (vendor=0x04b8 [EPSON], product=0x082f [USB MFP]) at libusb:002:002
> usb 0x04b8 0x082f
Is this in your epson.conf?  It should not be necessary.

> /etc/udev/rules.d/45-libsane.rules:
> # Epson CX3900
> SYSFS{idVendor}=="04b8", SYSFS{idProduct}=="082f", MODE="664", GROUP="scanner"

Does the scanner group exist on your system?  Are you a member of that
group?  If not, that might be the problem.

> and everything used to work, but this time does not... the only
> change on the system was that I used Slackware 12.0 and now 12.1,
> kernel configuration is the same...
> I read an article on internet that somebody had troubles when
> 'usblp' module was loaded (it loads on my system when the scanner is
> plugged)... tried again unloading the module before running xsane
> but still no scanning device is detected...

The usblp module is known to cause problems with some of the Epson MFP
devices but AFAIK not with any of the all-in-ones like your CX3900.

> The scanner is working on windows, so it is not the problem... I
> think it may be some library incompatibility but 't can't find
> nothing yet...
> Any suggestion?

Does your /etc/ld.so.conf include some reference to a lib/sane
directory?  It shouldn't.  Remove and run `ldconfig` to fix.

Otherwise, some debugging info might help.

Hope that helps,
Olaf Meeuwissen                   FLOSS Engineer -- AVASYS Corporation
FSF Associate Member #1962           sign up at http://member.fsf.org/

More information about the sane-devel mailing list