[sane-devel] SANE 1.0.19 does not find CX3900, 1.0.18 works but...

Olaf Meeuwissen olaf.meeuwissen at avasys.jp
Sun Aug 24 23:57:57 UTC 2008

Kanito 73 <kanito73 at hotmail.com> writes:

> Hi
> Well don't know what could be the problem, just returned to the
> previous version and it was working again... I guess something
> changed in the library with this particular model...
> Now have a new problem, can't access except as root, in any way can
> let a normal user to access the device, tried udev rules, to setuid
> the programs, cry and pray, but nothing works :S
> Thanks for your comments
>> Sounds identical to a problem I had. I don't really
>> understand it, but you can find more about it here:
>> http://bugs.gentoo.org/show_bug.cgi?id=225599

Have you tried disabling the epson2 backend?  Towards the end of the
bug report there is mention that the epson and epson2 backends might
be getting into one another's way.

You can disable backends in the /etc/sane.d/dll.conf file (or, IIRC,
on your system /usr/local/etc/sane.d/dll.conf).  You could also try
with the epson backend disabled.

Hope this helps,
Olaf Meeuwissen                   FLOSS Engineer -- AVASYS Corporation
FSF Associate Member #1962           sign up at http://member.fsf.org/

More information about the sane-devel mailing list