[sane-devel] Mustek BearPaw 2448CU pro

damianorossi at paranoici.org damianorossi at paranoici.org
Mon Dec 22 12:18:47 UTC 2008

On Sun, 21 Dec 2008 13:25:44 -0800 (PST), Jack McGill
<jmcgill85258 at yahoo.com> wrote:
> There was a thread about this same scanner last month.
> The author got about as far as you did.

I tried xscanimage. Setting correct scan area size motor moves properly.
But I don't understand the meaning of that red image. It doesn't depend on
what I put on the scanner.

> Next you are going to have to do some usb snooping on a windows machine
> using either http://www.pcausa.com/Utilities/UsbSnoop/ or
> http://benoit.papillault.free.fr/usbsnoop/.

I think I won't be able to read snoop logs. I'll post them.

> Then try to figure out the meaning of the snoop logs. Snoop logs are too
> big to post here, so you will need to find a free web site to post them
> I've used google site for this in the past.
> Jack McGill

Thank you for reply
Damiano Rossi

> --- On Sun, 12/21/08, Damiano Rossi <damianorossi at paranoici.org> wrote:
>> From: Damiano Rossi <damianorossi at paranoici.org>
>> Subject: [sane-devel] Mustek BearPaw 2448CU pro
>> To: sane-devel at lists.alioth.debian.org
>> Date: Sunday, December 21, 2008, 9:39 AM
>> I am an owner of the scanner Mustek BearPaw 2448CU pro and
>> I'd like to
>> use it on linux system. I'm not a programmer but since
>> there is a
>> backend for a similar scanner (BearPaw 2448 TA pro) I'd
>> like to do my
>> best to adapt mustek_usb2 backend to support this scanner.
>> I'm using ubuntu 8.10 but I downloaded last CVS
>> sane-backends
>> I changed line 148 in mustek_usb2.c from
>> SANE_FALSE,                    /* Is this a CIS scanner? */
>> into
>> SANE_TRUE,                    /* Is this a CIS scanner? */
>> Because 2448cu is a CIS scanner and not a CCD one like 2448
>> TA
>> I think that developer's intention was tu support CIS
>> sensors but maybe
>> the support is incomplete.
>> Then I replaced ProducId 0x409 with 0x408 in
>> mustek_usb2_asci.c
>> "BearPaw 2448CU Pro",         /* Device model
>> name */ (mustek_usb2.c
>> line 128)
>> sane_device->model = strdup ("BearPaw 2448 CU
>> Pro"); (mustek_usb2.c line
>> 2082)
>> Now scanner is recognized from lsusb
>> when I try to scan with scanimage leds get on, motor start
>> but it
>> doesn't stop at the end and bumps with a noisy
>> trrrrrrrrrrrrr until I
>> unplug the usb cable.
>> When I try to scan with xsane leds get on, motor moves and
>> suddenly
>> stops with a long beep.
>> In both cases it seems that rgb data are read but an image
>> made of thick
>> red vertical lines is returned as output
>> I tried to analyze the debug output setting
>> but in both cases there is no error. Each asic function
>> enter and exit
>> without errors.
>> What could I do at this point?
>> --
>> sane-devel mailing list: sane-devel at lists.alioth.debian.org
>> http://lists.alioth.debian.org/mailman/listinfo/sane-devel
>> Unsubscribe: Send mail with subject "unsubscribe
>> your_password"
>>              to sane-devel-request at lists.alioth.debian.org

More information about the sane-devel mailing list