[sane-devel] Problem: X-Server crashes when using XSane

"Christoph M. Schröder" cmschroeder at maxi-dsl.de
Sat Jun 21 12:42:04 UTC 2008

Hi everyone,

i got a problem and can't find any solution. So i hope you can help me.

I'm using XSane on Ubuntu 8.04. My scanner is an AGFA Snapscan 1236s

Yesterday i got a transparency adapter for it. At first for some hours
(with pauses) everything worked fine. I got great results.

But suddenly, (i think after i did some black and white negative scans),
i could not use the transparency adapter anymore. Every time i want to
use it now, the X-Server crashes up and starts from new (also when i
want to use the preview mode). There is only one exception: I can scan
(using the transparency adapter) in lineart mode (but only scan, no

Somewhere then i read, that it could help to downgrade libsane from
version 1.0.19 to 1.0.18. I did so. After this the X-Server dos not
crash up anymore, but i get the message "Konnte Scanner nicht starten
Fehler während Geräte I/O" (could not start scanner error while device I/O).

If it could be helpful you can find the logfiles of yesterday here:


Today at first it didn't work, then it worked for half an hour and now
it's not working again.

Thanks to everyone!


More information about the sane-devel mailing list