[sane-devel] problems getting xsane to read from Nikon Coolscan V

Steve Kelem s_kelem at pacbell.net
Tue Sep 9 18:28:09 UTC 2008

I am trying to use xsane with my Nikon Coolscan V ED scanner on Opensuse
11.0, Linux

When I run xsane as a user, I get:

    No devices available.

When I run xsane as root, xsane runs, will preview what's in the
scanner, but if I press Scan, the scanner motor hums for a split second
and then xsane issues the error:

    Error during read: Error during device I/O.

I read http://www.sane-project.org/README.linux, and have the following

        scanimage -L

scanimage -L reports:

    device `coolscan2:usb:libusb:002:007' is a Nikon    LS-50 ED        
    film scanner

for both user and root.


There is nothing in /proc/bus/usb.



    found USB scanner (vendor=0x04b0 [Nikon], product=0x4001 [LS-50 ED])
    at libusb:002:007


I'm running libusb-0.1.12-110.1
/etc/udev/rules.d contains 55-libsane.rules, which contains the
following lines:

    # Nikon LS 50 ED | Nikon Coolscan V ED
    SYSFS{idVendor}=="04b0", SYSFS{idProduct}=="4001", MODE="0664",
    GROUP="lp", ENV{libsane_matched}="yes"

So, the default group is "lp", not "scanner".


/etc/hotplug does not exist, and "locate" cannot find libsane.usermap or


Xsane version 0.995 (c) 1998-2008 Oliver Rauch (modified by Novell, Inc.)
sane-backends 1.0.19-48.1
sane-backends-autoconfig 1.0.19-48.1
sane-frontends 1.0.14-250.1

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20080909/ae749931/attachment.htm 

More information about the sane-devel mailing list