[sane-devel] Lexmark x1150 works with lexmark backend

Jochen Ehmen jomen at gmx.de
Fri Dec 18 10:26:47 UTC 2009


I try to reply to a message from the archive and hope it gets to the
proper place.

Despite the report of Stef (February 23 2009) I want to report, that the
lexmark backend is NOT working for me.

I also have a Lexmark X1150.

I use Gentoo and tried all versions available.

It IS working with sane-backends-1.0.18 
(the working ebuilds name is: media-gfx/sane-backends-1.0.18-r6).

If I use any newer version - such as 1.0.19 or 1.0.20 -
the scanner just makes noise, it starts to scan and immediately pulls
back, starts again and pulls back and so on until I kill the program.
Tried with scanimage, xscanimage and xsane.

Some change between 1.0.18 and 1.0.19 seems, therefore, to be the cause.

I'd like to help identify the problem, but would need assistance in
doing so.
I'll gladly answer all questions in order to help.

As far as I can see the ebuilds do no change to the source files - just
some udev-rules are patched in and the "-fno-strict-aliasing"
compiler-flag is added in version 1.0.20.



More information about the sane-devel mailing list