[sane-devel] xsane and scanimage crashes

J.S bluedbs at gmail.com
Wed Mar 11 02:27:59 UTC 2009

My system specs:
	slackware 12.2
`	gdb v6.8
	xfce 4.4.3
	xscanimage (sane-frontends) 1.0.14
	scanimage (sane-backends) 1.0.19; backend version 1.0.19
	HP Scanjet 5300C

My systems has verified my scanner. From my system command outputs I have this:

Bus 001 Device 002: ID 03f0:0701 Hewlett-Packard ScanJet 5300c/5370c

#scanimage -L
device `avision:libusb:001:002' is a Hewlett-Packard ScanJet 5300C flatbed scanner

found USB scanner (vendor=0x03f0, product=0x0701) at libusb:001:002

#cat message
kernel: usb 1-2: new full speed USB device using ohci_hcd and address 2
kernel: usb 1-2: configuration #1 chosen from 1 choice
kernel: usb 1-2: New USB device found, idVendor=03f0, idProduct=0701
kernel: usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
kernel: usb 1-2: Product: Hewlett Packard ScanJet 5300C
kernel: usb 1-2: Manufacturer: Hewlett Packard

I'm not sure how to properly bring up debug errors with gdb, but this is what I have so far. To be specific, I tested this on a test machine running the above specs and xsane and scanimage crashes. I also
tested this on my primary machine running the same specs as shown above and it still crashes. I added my user to the scanner group. I was surprised that root wasn't listed. Then I plugged in my usb scanjet to
the computer and powered it on. I started up xsane and it was searching for my scanner device and the program detected it, good. Now in the main scanjet 5300C window, I clicked on "scan" and the program
crashed. I ran gdb and tried to reproduce this crash and I received the following from backtrace.

[Switching to Thread 0xb72ed6c0 (LWP 3415)]
0xb75c7061 in kill () from /lib/libc.so.6

#0  0xb75c7061 in kill () from /lib/libc.so.6
#1  0xb67816e4 in sanei_thread_kill () from /usr/lib/sane/libsane-avision.so.1
#2  0xb676cb4a in ?? () from /usr/lib/sane/libsane-avision.so.1
#3  0x00000000 in ?? ()

I ran xsane again and I clicked on "acquire preview" in the preview window and the program crashed. I ran gdb again and tried to reproduce this crash and I received the following from backtrace.

Program received signal SIGTERM, Terminated.
[Switching to Thread 0xb73266c0 (LWP 3750)]
0xb7600061 in kill () from /lib/libc.so.6

#0  0xb7600061 in kill () from /lib/libc.so.6
#1  0xb67ba6e4 in sanei_thread_kill () from /usr/lib/sane/libsane-avision.so.1
#2  0xb67a5b4a in ?? () from /usr/lib/sane/libsane-avision.so.1
#3  0x00000000 in ?? ()

Basically the program crashes when I click on "scan" in the main window and "acquire preview" in the preview window. From the above errors, I'm thinking it's a problem with the driver I'm using which is
"libsane-avision" driver. I checked my scanner with a windows pc and it runs, scans, and saves images with no problems.

I opened up the configuration for avision which was located at /etc/sand.d/ directory, and it contained the exact following info:

# This are the possible options. Normally any scanner
# should work just fine without them - and they are only
# needed for test and debugging. So if you experience problems
# and you solve them with enabling options here, please notify
# the SANE/Avision maintainer: Rene Rebe <rene at exactcode.de>

#option disable-gamma-table
#option disable-calibration
#option force-a4

#scsi FCPA
#scsi HP
#scsi hp

#scsi /dev/scanner
# usb libusb:002:003
# usb 0x03f0 0x0701

More information about the sane-devel mailing list