[sane-devel] Unable to scan over the network with Canon Pixma MP190 (Sane 1.0.20)

Sergi de Pablos sdepablos at gmail.com
Sat Apr 3 00:02:11 UTC 2010


I suppose I'm neither the first nor the last with this problem, but I don't
know where else to look or ask.

I'm trying to scan over my lan with my Canon Pixma MP190. The server is a
NSLU2 running Debian Lenny (, and the client an Ubuntu 9.10
(, both of them with the last sane version (v1.0.20). From the
server everything works ok as root or as user, but on the client if I run
saned as a service I can detect the scanner (with scanimage -L) but unable
to scan ("Access to resource has been denied"). If I start sane in debug
mode (saned -d128) everything works ok from the client and I'm able to scan.
I've double checked everything: I've added saned to te scanner group (addgroup
saned scanner), edited /etc/sane.d/saned.conf and added,
defined the sane-port service ( cat /etc/services | grep sane --> sane-port
6566/tcp sane saned # SANE network scanner daemon), configured /etc/inetd.conf
(sane-port       stream  tcp     nowait  saned:saned     /usr/sbin/saned
saned), restarted inetd (/etc/init.d/openbsd-inetd restart) and added the
scanner in the client to /etc/sane.d/net.conf ( Below you
could see the output as a service and in debug mode. I've tried to debug as
service in the server side, calling the following script which in turns call
saned (renamed to saned.bin) , but the error log is always empty:

export SANE_DEBUG=255
cd /tmp
exec $0.bin 2> saned.$$.stderr


More information about the sane-devel mailing list