[sane-devel] Canon DR-2020U incompatible with canon_dr

Pierre Willenbrock pierre at pirsoft.dnsalias.org
Mon Apr 19 20:12:21 UTC 2010

m. allan noah schrieb:
> On Mon, Apr 19, 2010 at 10:33 AM, Fabian Eichstädt <f.eichstaedt at fabz.de> wrote:
>> Hi all!
>> We recently aquired a Canon DR-2020U scanner and I tried to test it
>> with a recent sane git-snapshot. It compiled without problems and
>> I tried to use it with the canon_dr backend. This failed.
>> Allan Noah told me that this model uses a very different control method
>> than the other "DR" scanners and thus the canon_dr backend cannot work.
>> I made a scan with Windows XP and logged the USB Commands with USBSnoop.
>> This logfile is available for download here (ca. 4.3 MB):
>> http://dl.dropbox.com/u/3879521/CANON-DR2020U_UsbSnoop.log.bz2
>> Maybe this is helpful for somebody interested in creating a suitable backend
>> for this scanner. I would be glad to be able to use this scanner with Linux.
> Looks like mostly alot of 1 or 2 byte control transfers, with bulk for
> the image data. Perhaps one of the genesys authors could look at it?

This decodes fine assuming genesys gl842 or gl843 protocol and at least
the frontend registers and status registers are at the right place. This
machine has a register space going up to (at least) register 0xff, so it
is not one of the currently supported chip versions. Also, my script
finds at least one unknown control transfer.


More information about the sane-devel mailing list