[sane-devel] canon lide 50 on amd64 fails?

Jutta Zalud ju at netzwerklabor.at
Sun Aug 29 05:59:38 UTC 2010

> On Tue, Aug 24, 2010 at 1:12 AM, Oleg Mikheev <omikheev at gmail.com>
> wrote:
> > Hi guys,
> >
> > I have Mustek 1200 UB Plus working perfectly fine
> > on Gentoo 32 bit on a no-name laptop.
> > Exactly the same scanner refuses to work on Gentoo
> > amd64 on Thinkpad X201i.

I have a similar problem with a Canon Lide 50 and Debian Sid amd64 on a
Thinkpad T410. The scanner works fine on my old Compaq Presario 2800
with Debian Lenny. But on the amd64 I only get black images, the head
of the scanner does not move. 

Sometimes the scanner also seems to just disappear and won't be listed
in scanimage -L. (A reboot solves this, I have not found a better
method yet.)

I am quite new to sane (with the old notebook the scanner just worked,
so I never had to think how and why) and I tried to figure out the
debugging-commands from what I read. If they are just stupid, please
tell me :)

jutta at T410:~/test$ scanimage -L
device `v4l:/dev/video0' is a Noname Integrated Camera virtual device
device `genesys:libusb:001:007' is a Canon LiDE 35/40/50 flatbed scanner
jutta at T410:~/test$ 

jutta at T410:~/test$ SANE_DEBUG_SANEI_USB=255 SANE_DEBUG_GENESYS=255
scanimage --device-name genesys:libusb:001:007 --resolution 150
--format tiff > test-druck.tiff 2>lide50b.log

The output is more that 3000 lines long, I copied it to 



More information about the sane-devel mailing list