[sane-devel] Ubuntu 10.4 32 & 64 bit Platform - Canon MF6550 Scanner - sane via any frontend "Hangs" at 1st data transfer

Nicolas Martin nicolas0martin at gmail.com
Thu Jul 1 19:28:41 UTC 2010

Sending here, answer posted in bug tracker, with adequate formatting.

The Sane lib 1.0.20 released with Ubuntu 10.04 does did have some
declarations for the MF65xx series, but was untested, due to lack of

Until recently, some guy tried to use its MF6580 under MacOSX, he sent
me some usb snoops and I've added a few changes in the git version for
this model. 

Unfortunately, we ran then into big troubles trying to test that on Mac
OS X, getting messed up with twain-sane and Darwin libusb ;-(

So if you are running Ubuntu, I would recommend you install the git Sane
and give a fresh try with it. 
You can get help for that with the following blog post:

Then, get a logtrace as follows:

$ export SANE_DEBUG_PIXMA=11

$ scanimage   2> scanimage.log 

Send back the scanimage.log file you'll get, for analysis.

Note: On Ubuntu 10.04, you'll probably get into trouble with
permissions, so create a file /etc/udev/rules.d/mylibsane.rules and put
the following content into it:

# libusb device nodes : change permissions to 666
SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", MODE="0666"

Then, either restart udev, or reboot before trying to run scanimage as
non root user.


Le mercredi 30 juin 2010 à 16:27 -0500, Ron Parker a écrit :
> @
> https://alioth.debian.org/tracker/?func=detail&atid=410366&aid=312616&group_id=30186
> I said:
> "I am new to linux scanning, but have looked at the work being done
> for CANON imageclass MF6550 for a year or so. The backends releasd
> with Ubuntu 10.4 seems to be "almost" there.
> Using the XSANE frontend, for example, The scanner model is properly
> identified, and the GUI allows me to request a regular scan or preview
> scan. 
> SYMPTOM: When a (flatbed) scan is initiated, the scan head appears to
> make a registration move, then makes a full 14 inch pass of the
> scanning bed, and then returns to its home position.
> The UBUNTU system "locks" as though it is waiting for a data transfer
> handshake that never happens. No image is returned. This is good for
> ONE attempt. subsequent attempts to scan result in error messages.
> Disconnecting and reconnecting the scanner from the system is not
> sufficient to "clear" the hang. The ubuntu system must be reset.
> So, I am able to recognize the scanner, activate one pass of the scan
> head, and then nothing. I tried this initially under 10.4 (32 bit) and
> after migrating my systems to 64 bit repeated the test with the same
> result.
> I  see that the scanner project wants testers for this model of
> scanner. I would be happy to help, but I will need some hints (e.g.
> where log files might be created. What command I should use to see
> sane process status, a command line option that would isolate and test
> the backend before we bring in GUI frontends to the mix.)
> Ron "
> PS
> Following advice by Nicholas, I am submitting this to the DEV list,
> building an ubuntu library from the "git', and will try to capture
> some test results this evening.
> cd /usr/src
> git clone git://git.debian.org/sane/sane-backends.git
> cd sane-backends
> apt-get install libusb-dev
> ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
> make
> make install
> --
> sane-devel mailing list: sane-devel at lists.alioth.debian.org
> http://lists.alioth.debian.org/mailman/listinfo/sane-devel
> Unsubscribe: Send mail with subject "unsubscribe your_password"
>              to sane-devel-request at lists.alioth.debian.org

More information about the sane-devel mailing list