[sane-devel] Canon PIXMA MX350

Guenther Hutzl guenther.hutzl at googlemail.com
Sun Jul 4 15:30:19 UTC 2010


I have some good and some bad news! The scanner of my MX350 was once
working perfectly with the patch you provided. Thanks for all the great
work you are doing here! I really appreciate it. But now I cannot get it
to work any more and I don't know why.

Here is what I have done:

1. I have tested several different resolutions from 75dpi to 1200dpi and
it worked perfectly. Also the color/grayscale switch works as expected.
I used gimp together with the xsane dialog.
2. Then I tested the adf (automatic document feeder) to scan several
pages. I used skanlite for that. This also worked once.
3. After that I tried it again and I got the message:

Failed to open device 'pixma:MX350_192.167.1.88': Invalid argument.

I tried this with gimp and skanlite. When I start gimp via the
commandline I see this additional message after selecting my scanner in
the xsane device dialog and pressing OK:

[pixma] bjnp_open_tcp: Can not connect to scanner: Connection refused

I even rebooted my whole PC to rule out a hanging process that blocks
the scanner.

So how can that happen? I guess it is probably some config file that has
problems. I checked the scanner with a mac book and it works still fine,
so the scanner itself is not the problem. Just something with my linux
setup. I am using gentoo linux. I have hacked together a custom ebuild
of sane-backends that includes the mx350 patch. I have attached the two
files if anyone is interested. What can I do to analyze and rule oout
this problem? Is there some debug option somewhere? I did not see
anything in my system logs. I also tried scanimage from the commandline
and get the same error:

> scanimage  -d pixma:MX350_192.168.1.88 --format=pnm
[pixma] bjnp_open_tcp: Can not connect to scanner: Connection

scanimage: open of device pixma:MX350_192.168.1.88 failed: Invalid

Please help me, I think we are so close to having another supported
scanner in sane.


On 07/03/2010 04:42 PM, Nicolas Martin wrote:
> Could you try to recompile Sane with the attached file.
> Place it in sane-backends/backend to replace current git one, and
> recompile/reinstall Sane.
> Nicolas
> Le samedi 03 juillet 2010 à 15:33 +0200, Guenther Hutzl a écrit :
>>> If you can provide the USB pid for this model, we could try a quick
>>> test, as there's some chance that this model behaves like a MX340 or
>>> MX330, which are already supported. To get this, simply issue a lsusb ,
>>> the usb pid should be in the list shown.
>> This is the output of lsusb for the MX350:
>> Bus 001 Device 002: ID 04a9:1742 Canon, Inc.
>> Is this enough for a first try of do you need lsusb -v output?
>> I will use your instructions how to use snoopypro when I have the
>> windows PC available.
>> Thanks,
>> Guenther.
>> --
>> sane-devel mailing list: sane-devel at lists.alioth.debian.org
>> http://lists.alioth.debian.org/mailman/listinfo/sane-devel
>> Unsubscribe: Send mail with subject "unsubscribe your_password"
>>              to sane-devel-request at lists.alioth.debian.org
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: sane-backends-999.ebuild
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20100704/42faad5c/attachment.txt>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: mx350.patch
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20100704/42faad5c/attachment.asc>

More information about the sane-devel mailing list