[sane-devel] Canon PIXMA MX870

Matthias Pannek matthias at pannek.de
Sat Jul 17 15:36:58 UTC 2010

On Sat, 17 Jul 2010 14:44:00 +0200
Nicolas Martin <nicolas0martin at gmail.com> wrote:

> Matthias, before I commit the changes and update the docs, did you try
> the ADF and ADF duplex features, and do they work fine ? (remember to
> set 2 pages to scan per sheet of paper in ADF when in duplex mode)

First test was "ADF Duplex" but I forgot to set the page-count to 2,
then the printer stopped after 1 page but the paper was still in the
feeder. (waiting for the "reverse feeder")

After that the scanner/printer worked fine via the Display, but I
couldn't connect to the scanner.

[pixma] pixma_collect_devices() found Canon PIXMA MX870 at
bjnp://canon.saberhagen:8612 [pixma] pixma_open(): Canon PIXMA MX870
[pixma] sanei_bjnp_open(bjnp://canon.saberhagen:8612, 16843009):
[pixma] bjnp_allocate_device(bjnp://canon.saberhagen:8612)[pixma]
udp_command: Sending UDP command to [pixma]
bjnp_open_tcp: Can not connect to scanner: Connection refused [pixma]
pixma_connect() failed EINVAL [pixma] pixma_open() failed EINVAL
[pixma] pixma_close(): Canon PIXMA MX870
scanimage: open of device pixma:MX870_canon.saberhage failed: Invalid

Scanimage logfiles:

Nmap scan report for canon.saberhagen (
Host is up (0.0051s latency).
Not shown: 9992 closed ports
137/udp  open          netbios-ns
138/udp  open|filtered netbios-dgm
500/udp  open|filtered isakmp
3702/udp open|filtered unknown
5353/udp open          zeroconf
8611/udp open          unknown
8612/udp open          unknown
8613/udp open          unknown
MAC Address: 00:1E:8F:99:BD:B7 (Canon)

I turned the power off and on....same problem. Then i unplugged the
scanner for ~10 seconds and it worked again.

Now for the test (xsane):
Flatbed: working fine (preview/scan/cancel/....) up to 2400 DPI.

ADF: Working until 600 DPI, i tried it with 1200 DPI and i just got a
"Error during read: Error during device I/O". Error and the scanner
stuck with a "Processing..." message until Power off/on.
(I know, max ADF resolution is 600 DPI)

ADF without a paper in the feeder: Error message "Error during read:
Document feeder out of documents". But the scanner itself is stuck with
the "Processing..." screen. After 5 minutes still at processing, seems
there is no timeout for this. The abort key don't work, so only Power
off/on helps again.

ADF Duplex 600 DPI (page count 2):  working fine without a problem.

This should be all :-)


More information about the sane-devel mailing list