[sane-devel] What happens with Epson support?

Olaf Meeuwissen olaf.meeuwissen at avasys.jp
Mon Jul 26 23:44:25 UTC 2010

Hash: SHA1

On 2010-07-27 06:24, Mogens Jæger wrote:
> Den 26-07-2010 02:38, Olaf Meeuwissen skrev:
>> [snip]
>> As Allen suggested, logs may be helpful answering that but I'd prefer
>> logs generated using the distribution's package over a git snapshot.
>> This ought to do the trick for the epson backend.
>>   SANE_DEBUG_EPSON=127 scanimage > image 2> epson.log
>> Just replace the backend names for epson2 and/or epkowa.
> This is very weired - first I have to say, that I by far is a
> programmer, I'm mostly on the list, because I participate in the
> localization.
> I had been using the scanner with the 1.0.19 'install', and then I did a
> upgrade to the 1.0.21 - and it still works. See epson2.log
> Then I turned the scanner off, and later back on (without having the
> computer turned off) and it still replied to the 'debug' script.
> So I started the Xsane, but it could not find any scanner.
> Then I ran the Yast-setup program for the scanner, and it found the
> scanner, but could not install it.
> I then installed the newest version of iscan (2 - both the data and
> driver pakage) - still no go.
> Back to the 1.0.19 and all is working again - see epson2-19.log
> My conclusion is, that it's not the epson2 package/driver that is the
> problem, but somewhere in the Suse system (in Suse 11.2 and earlier
> versions I had manually to ad user rights to the scanner. This is fixed
> in 11.3) - there are 2 packages, the sane-backens and a
> sane-backends-autoconfig. I have tried to only upgrade the sane-backends
> package, but no difference.

Both the logs that you attached looked fine.  There does not seem to be
anything wrong with the epson2 backend in this case.  I agree with your
conclusion and suggest you submit a bug report with SUSE.

Hope this helps,
- -- 
Olaf Meeuwissen, LPIC-2           FLOSS Engineer -- AVASYS CORPORATION
FSF Associate Member #1962               Help support software freedom
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/


More information about the sane-devel mailing list