[sane-devel] Ubuntu 10.4 32 & 64 bit Platform - Canon MF6550 Scanner - sane via any frontend "Hangs" at 1st data transfer

Ron Parker mail at ronparker.us
Wed Jun 30 21:27:56 UTC 2010

@ https://alioth.debian.org/tracker/?func=detail&atid=410366&aid=312616&group_id=30186 

I said: 

"I am new to linux scanning, but have looked at the work being done for CANON imageclass MF6550 for a year or so. The backends releasd with Ubuntu 10.4 seems to be "almost" there. 

Using the XSANE frontend, for example, The scanner model is properly identified, and the GUI allows me to request a regular scan or preview scan. 

SYMPTOM: When a (flatbed) scan is initiated, the scan head appears to make a registration move, then makes a full 14 inch pass of the scanning bed, and then returns to its home position. 

The UBUNTU system "locks" as though it is waiting for a data transfer handshake that never happens. No image is returned. This is good for ONE attempt. subsequent attempts to scan result in error messages. Disconnecting and reconnecting the scanner from the system is not sufficient to "clear" the hang. The ubuntu system must be reset. 

So, I am able to recognize the scanner, activate one pass of the scan head, and then nothing. I tried this initially under 10.4 (32 bit) and after migrating my systems to 64 bit repeated the test with the same result. 

I see that the scanner project wants testers for this model of scanner. I would be happy to help, but I will need some hints (e.g. where log files might be created. What command I should use to see sane process status, a command line option that would isolate and test the backend before we bring in GUI frontends to the mix.) 

Ron " 


Following advice by Nicholas, I am submitting this to the DEV list, building an ubuntu library from the "git', and will try to capture some test results this evening. 

cd /usr/src 
git clone git://git.debian.org/sane/sane-backends.git 
cd sane-backends 
apt-get install libusb-dev 
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var 
make install 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20100630/9fb02182/attachment.htm>

More information about the sane-devel mailing list