[sane-devel] Epson Artisan 710 support

Grant emailgrant at gmail.com
Fri May 14 19:47:54 UTC 2010

>> I tried a few different frontends including Image Scan and they all
>> produced the same horizontal lines.  Increasing the scan resolution
>> from 300dpi to 600dpi prevents the lines from appearing, but Image
>> Scan is the only frontend I've found that makes 600dpi available.
>> xsane and xscanimage both make 600dpi available on the Y axis, but the
>> available X axis resolutions jump from 300dpi to 1200dpi.
> The x and y resolution lists for this scanner should be the same. This
> sounds like this bug:
> http://lists.alioth.debian.org/pipermail/sane-devel/2008-July/022433.html
> I believe this bug was fixed quite a while ago. What version of SANE are you
> using? You may want to update to the latest version. This may require some
> compilation work on your part, though.

You're right, I was using 1.0.19 and upgrading to 1.0.21 enabled
600x600 resolution.

>> The problem with Image Scan is it doesn't seem to have proper correlation
>> between the preview UI selector borders and the resulting scanned image.
> Because the preview is a highly scaled down version of the final output,
> there is bound to be some error when selecting the area. Could that account
> for the discrepancy you are seeing or is it really that big?

It's really only slightly off, but xsane seems significantly more
accurate if you're trying to get it just right.

> With regards to the horizontal lines, could you send me a sample scan
> off-list? Preferably a fairly small area exhibiting the problem scanned at a
> high resolution in a lossless format, like PNG. I don't want to go hunting
> for the problem if it is difficult to spot. Also, to avoid any image
> processing, please make sure to use scanimage to do the scan.

I'll email you directly right now.

>> It also doesn't seem to allow the disabling of image processing.
>> Is there any way to try the epson2 backend's Artisan 700 support with
>> my Artisan 710?  epson2 doesn't support the 710 yet.  Maybe there's a
>> way to alter the scanner's USB device ID as it's presented to SANE?
> I am not sure what is necessary to get epson2 to recognize the Artisan 710.
> But likely all you need to do is add the USB id to /etc/sane.d/epson2.conf
> as indicated in that file.

I tried that but xsane it would only let me choose Lineart and 72dpi.

> This is something I mailed the list about before, but the "Unsupported"
> status of the Artisan 710 and other scanners like it in epson2 is
> unwarranted. These devices are labeled as unsupported because epkowa.desc
> mentions a proprietary plugin for those models. This plugin, however, is
> only necessary for network support when using the epkowa backend and not at
> all necessary for the epson2 backend, even when using the scanner via the
> network interface.

I'm not so sure about that.  The Epson Artisan 700 is listed as
supported, and it is almost identical to the 710.  I owned the 700

- Grant

> As I mentioned before, when identifying interpreter based models in
> epkowa.desc the correct search term is: "requires DFSG non-free" or just
> "requires DFSG". I suspect that currently "DFSG" or "non-free" is being used
> which ends up including the models that mention the proprietary network
> plugin.

More information about the sane-devel mailing list