[sane-devel] Epson "Expression 10000XL" ADF support by epson2

Olivier Jolit olivier.jolit at hotmail.fr
Fri Nov 19 10:21:41 UTC 2010

> > Hello,
> Hi
> > I need to use the ADF of the Epson Expression 10000XL (backend 
> > epson2), but cant get it to work properly. The ADF always tries to 
> > take the next sheet on the stack when scaning a sheet.
> Have you tried the epkowa backend (part of Image Scan! for Linux)? The
> latest release, announced here just today contains several ADF related
> fixes.
Thank you for your advice, unfortunately I cant get epkowa to detect my scanner, even when specifying  
"usb 0x04b8 0x0129 #Epson 10000XL" in epkowa.conf (values coming from lsusb)
I get the following run:
 [sanei_debug] Setting debug level of dll to 127.
 [dll] sane_init: SANE dll backend version 1.0.12 from sane-backends 1.0.21
 [dll] sane_init/read_dlld: processing /usr/local/etc/sane.d/dll.d ...
 [dll] sane_init/read_dlld: done.
 [dll] sane_init/read_config: reading dll.conf
 [dll] add_backend: adding backend `epkowa'
 [dll] sane_get_devices
 [dll] load: searching backend `epkowa' in `/usr/local/lib/sane'
 [dll] load: trying to load `/usr/local/lib/sane/libsane-epkowa.so.1'
 [dll] load: dlopen()ing `/usr/local/lib/sane/libsane-epkowa.so.1'
 [dll] init: initializing backend `epkowa'
 [dll] init: backend `epkowa' is version 1.0.212
 [dll] sane_get_devices: found 0 devices
 No scanners were identified. If you were expecting something different,
 check that the scanner is plugged in, turned on and detected by the
 sane-find-scanner tool (if appropriate). Please read the documentation
 which came with this software (README, FAQ, manpages).
 [dll] sane_exit: exiting
 [dll] sane_exit: calling backend `epkowa's exit function
 [dll] sane_exit: finished
So my scanner isn't detected (and it is when i comment epkowa in dll.conf and uncomment epson2).
By the way, SANE_DEBUG_EPKOWA doesnt seem to be effective, even if epkowa is loaded (although SANE_DEBUG_EPSON2 works, so maybe libepkowa was build without debug support).
I couldnt find where to download the latest epkowa release you were speaking about, is it in the git repo? Currently I have sane-backends 1.0.21 which seems to me to be the latest available binary) and I'm using the epkowa library "libsane-epkowa.so.1.0.15".
I also tried directly :
sudo scanimage -d epkowa
scanimage: open of device epkowa failed: Access to resource has been denied

So not working either, is there another way to check if epkowa supports this particular device ?

> > [...] sheet will be half-way into the ADF at the end of the scan and
> > one need to manually remove it (with strength ^^).
> If you open the cover(s) on the sides of the ADF unit the pages should
> move more easily.
thank you, this might improve its life expectation ^^

> > Besides, "eject" options and "auto-eject=on" don't work with this 
> > scanner, maybe it is linked I don't know...
> It this also the case with the epkowa backend?
Well, don't know yet :)
> Hope this helps,
Hope too, and thank you again for your time
> - -- 
> Olaf Meeuwissen, LPIC-2 FLOSS Engineer -- AVASYS CORPORATION
> FSF Associate Member #1962 Help support software freedom
> http://www.fsf.org/jf?referrer=1962
> Version: GnuPG v1.4.10 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
> iEYEARECAAYFAkzlv7wACgkQt5qrxaZLMnJIqwCgpf5RsyKF3fWxh71Hcr3B9cuB
> 6+sAoIuJa6IcAjUJ9Ujr4z+OeCWf3rfu
> =TGFv
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20101119/6728bc27/attachment-0001.htm>

More information about the sane-devel mailing list