[sane-devel] plustek 0.52-3 backend: help needed!

Simon Matter simon.matter at invoca.ch
Wed Nov 24 13:58:03 UTC 2010

> Dear SANE developers
> I'm trying to get my hp scanjet 2100c flatbed scanner working with SANE
> under Ubuntu 8.04LTS but I realise I'm completely out of my depth.  I’m
> currently trying to find someone who could lead me through this maze in
> words of one syllable (or less)....
> SANE appears to recognise my scanner, but when I press 'scan' the thing
> just makes a 'clunk' and stops.  A similar noise is heard if I then press
> 'cancel'.  It seems that someone else has experienced this before:
> http://newyork.ubuntuforums.org/showthread.php?t=1248834
> I visited the SANE-project website and found a link to a backend that
> supported my scanner:
> http://www.gjaeger.de/scanner/plustek/    (backend file:
> plustek-usb-0.52-3.tar.tar).  Further reading revealed that this needed to
> be compiled into something that could be used by Ubuntu (something I’ve
> never done before).
> At this point I discovered the excellently-written  HowTo   document:
> https://help.ubuntu.com/community/CompilingEasyHowTo.  My optimism soared
> (!) and I decided to have a go.  I got to the point in Step 3 where it
> says “This newly-created directory will contain a file called 'configure'”
> - mine didn't(!!) As optimism gave way to desperation, I tried running
> anything that looked remotely like it might be a configuration file (as a
> few more besides).

Wait a minute before messing with your installation. The scanner you have
doesn't seem to be a very new model, which is good.
I have an Epson	Perfection 1260 at home which may be similar and I
recently discovered something new when I migrated my home laptop to CentOS
5 from some old Fedora version. With the new system the scanner didn't
seem to work but I couldn't understand why it shouldn't. I finally worked
but after starting a scan I had to wait quite some time (minutes?) until
the device really started. So I checked /etc/sane.d/plustek.conf just to
realize that the defaults for the lamp warming up have changed.
You may try to change "option warmup" and maybe also the others like
lampOff and lOffOnEnd.


More information about the sane-devel mailing list