[sane-devel] support for Canon MG8150

Gernot Hassenpflug aikishugyo at gmail.com
Sun Oct 31 22:36:59 UTC 2010

On Mon, Nov 1, 2010 at 4:41 AM,
<ralph.gauges at bioquant.uni-heidelberg.de> wrote:
> I tried to use the device over ethernet and this seems to work better:
> Quoting Gernot Hassenpflug <aikishugyo at gmail.com>:
>> On Mon, Nov 1, 2010 at 2:19 AM,
>> <ralph.gauges at bioquant.uni-heidelberg.de> wrote:
> Now I fixed the ids again and the device is recognized as an MG8100 device
> over USB as well, but I still get the I/O error.
> So right now, scanning over ethernet works, but over USB it doesn't work
> yet.
> Since the driver seems to be able to talk to the device, this is likely
> something small.
> What can I do to track down the USB problem and what tests can I run to make
> sure the device works as expected? Is there a standard set of tests to run?


Great to hear that the device works at least over ethernet. I am
afraid I do not know (yet) how to solve USB issues, perhaps you can
activate the sane USB debug environment variables (see the various
sane-* man pages, "apropos" should show you them) and send the output
of that when you try sane as root (maybe better than sudo for this

ISP Asahi-Net: http://asahi-net.jp/en/
No.1 in Japan by customer satisfaction
(Nikkei News, 7 July 2010)

More information about the sane-devel mailing list