[sane-devel] NO scanner is now recognized. :(

Mr Fair Go mrfairgo at mrfairgo.com
Mon Sep 27 05:07:04 UTC 2010

 >> I compiled and installed the latest sane-backends-1.0.21 and tried to
>> use it with a Canon DR-2010C scanner,


I have a Canon  MX310 which was scanning OK, but only in colour.  There was
some sort of bug in Greyscale and B&W.  I attempted to "compile and install"
the newer sane backends also, but as a newbie I clearly did something wrong,
because now none of my Linux scanning software will find the Canon or any
other scanner (I have 3).  I even uninstalled and reinstalled SANE and
gscan2pdf via the Package Manager, but still "

Can someone point me to a *very basic* Linux how-to that explains for a
newbie exactly how to "compile and install" with Linux?  Everything I look
at assumes I have more knowledge about "compiling" than I actually have.

Running LinuxMint 9 (Isadora) which is built on Ubuntu, for nearly a year
now.  Up to this point upgrading and installing packages via Package Manager
has been adequate for my needs, but the newer version is not available this
way, thus I attempted the more challenging route, but can not find
"instructions" anywhere.


Mr Fair Go

(They call me "Mr Fair Go")
fairgohomes.com.au -->a Fair Go for aspiring homeowners, sellers, investors,
fairgocom.net.au -->a Fair Go for Getting Your Life & Privacy Back!
eservers.com.au -->Professional Internet Hosting

On Mon, Sep 27, 2010 at 1:12 PM, Ori Koren <ori at paperact.com> wrote:

> On Sat, Sep 25, 2010 at 8:28 PM, Simon Matter <simon.matter at invoca.ch>
> wrote:
> >> Hi,
> >>
> >> I compiled and installed the latest sane-backends-1.0.21 and tried to
> >> use it with a Canon DR-2010C scanner,
> >> but the scanner is not recognized (by scanadf -L, or scanimage -L).
> >> sane-find-scanner and lsusb can see the device.
> <snipped>
> >> Am I missing some option in one of the config files?
> <snipped>
> >> I am using an ubuntu 8.04.3. The libusb-0.1-4, libusb-dev versions are
> >> both 2:0.1.12-8
> >
> > What about permissions? Did you try as root also? And is the backend in
> > question enabled in your sane config?
> >
> OK, it's working now.
> The thing that was missing was to add "canon_dr" to /etc/sane.d/dll.conf
> > Simon
> Thanks,
> Ori
> --
> sane-devel mailing list: sane-devel at lists.alioth.debian.org
> http://lists.alioth.debian.org/mailman/listinfo/sane-devel
> Unsubscribe: Send mail with subject "unsubscribe your_password"
>             to sane-devel-request at lists.alioth.debian.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20100927/d77362f3/attachment.htm>

More information about the sane-devel mailing list