[sane-devel] Device Selection

Olaf Meeuwissen olaf.meeuwissen at avasys.jp
Fri Dec 16 00:40:30 UTC 2011

CACook at quantum-sci.com writes:

> Anyone have any ideas?
> On Tuesday, December 13, 2011 07:03:57 AM CACook at quantum-sci.com wrote:
>> On Sunday, December 11, 2011 03:42:26 PM Olaf Meeuwissen wrote:
>> > > # sane-find-scanner
>> > > ...
>> > > found USB scanner (vendor=0x138a, product=0x0007) at libusb:003:004
>> > >   # Your USB scanner was (probably) detected. It may or may not be supported by
>> > >   # SANE. Try scanimage -L and read the backend's manpage.
>> > 
>> > Is this your scanner?  Looks like a VFS451 Fingerprint Reader to me[1].
>> > At the very least none of the SANE backends don't mention they support
>> > this device.  Nor do the external backends.
>> Hi, no it's a Canon MP460 multifunction printer/scanner.
>> It must be that the device found on the client was the fingerprint
>> reader on my HP Elitebook where I ran sane-find-scanner.  For some
>> reason it is not referring to port 6566.

I believe sane-find-scanner was written to look for local scanners only.
As such it will not attempt to find networked devices.

>> On the server where the scanner is connected the device shows in lsusb as:
>>  Bus 001 Device 006: ID 04a9:1716 Canon, Inc. MP460 Composite
>> ... and sane-find-scanner:
>> found USB scanner (vendor=0x04a9 [Canon], product=0x1716 [MP460]) at libusb:001:006

This device is reportedly supported by the pixma backend (0.16.1) of the
latest stable sane-backends release (1.0.22).

>> On Sunday, December 11, 2011 03:58:49 PM m. allan noah wrote:
>> > Try this:
>> > 
>> > SANE_DEBUG_DLL=15 scanimage -L 2>dll.log
>> # SANE_DEBUG_DLL=15 scanimage -L 2>/home/carl/dl/dll.log
>> No scanners were identified.

IIRC, that log was taken on the client.  Can you scan on the server?  If
you can, it's probably a network related configuration issue.

Hmm, going up the thread I noticed you wrote:

> OK there's more to the story: My saned server is running on Hex, where
> the scanner is.  I'm using a reverse SSH tunnel to serve 6566 on
> Droog.  So 6566 appears on Droog as localhost:6566 yet the server is
> actually on Hex.  For years I've remotely served services like this
> such as Squid, MythTV, Cups, etc, and they all (still) work.  It is a
> great secure method.  I am seeing localhost:6566 on Droog, just as I
> should, and there are no firewall errors.  But XSane is not using it.

Your /etc/sane.d/net.conf has localhost enabled, right?  Debian doesn't
enable it by default.

Your saned process have read/write access to the device, right?  There
are (were?) distributions where scanners are configured for read/write
by one system group and saned runs as another ...

> Xsane runs fine on Hex, and when I stop saned it can no longer find
> any devices, so I know XSane is using saned on Hex.  For some reason
> though, XSane is not finding the server on Droog.
> Is there anything I should know about XSane's use of saned?

I'm not quite sure I understand your setup but ...

How would XSane deal with the SSH authentication?  Does it have to?
Can you telnet to localhost:6566 on Droog?  Have you tried capturing
network packets?

Hope this helps,
Olaf Meeuwissen, LPIC-2           FLOSS Engineer -- AVASYS CORPORATION
FSF Associate Member #1962               Help support software freedom

More information about the sane-devel mailing list