[sane-devel] can only scan as root

stef stef.dev at free.fr
Thu Feb 3 20:17:42 UTC 2011

Le Thursday 03 February 2011 16:11:48 Linda Hanigan, vous avez écrit :
> I found some instructions to get a Canon LiDE 200 scanner working on Lucid.
> http://www.uluga.ubuntuforums.org/showthread.php?t=1161276&page=2  It has
> sorted of worked. I have everything installed and if I run xsane or
> simple-scan as root it will run, but as a user it fails to detect a
> scanner.  The solutions I have found online say to add users to saned and
> scanner groups. I added the users to saned, but I don't have a scanner
> group.  I aslo found instructions that suggested you do the following add
> a new file as
> /etc/udev/rules.d/40-scanner-permissions.rules with the following contents
> # usb scanner SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", MODE:="0666"
> SUBSYSTEM=="usb_device",MODE:="0666" I did this as well and rebooted but I
> still can not scan except as root. If I run scanimage -L  It says no
> scanners were identified. However if I run sudo scanimage -L It says
> device
> 'genesys:libusb:002:003' Is a canon LiDE Flatbed Scanner. The computer is
> running Ubuntu 10.04 LTS  Any ideas on how I can get the scanner to work
> without running it as root?  Thank you so much for any help you can give
> me to get this to work properly.         Linda

	may be you could try the following PPA: https://launchpad.net/~stef-
dev/+archive/sane-backend-genesys .


More information about the sane-devel mailing list