[sane-devel] HP Scanjet 8270 / Avision backend / user permissions

Olivier Crouzet olivier.crouzet at univ-nantes.fr
Mon Jan 10 15:28:16 UTC 2011

Dear Julien, dear all,

I also cc this message to the adress that is indicated for bugs
information on the SANE/avision backend page.

Julien, thanks for the help. Looking at doc/descriptions/avision.desc
in the source tree, the file says it is actually computed automatically
from avision.c

As a matter of fact, only the HP 8250 & 8290 are mentionned in
doc/descriptions/avision.desc although the HP 8270 is mentionned in
avision.c so I tried modifying avision.c (basic modifications)
according to how I thought it may have any impact on this issue to no
avail... I also tried to add the parts corresponding to the 8270
checking for the correct model number directly into avision.desc,
recompiling and reinstalling, to no avail neither.

Then I tried recompiling the package with the original development
files for the avision backend and it suddenly started working as a
regular user (but I'm perfectly unable to locate the reason why it
worked as I thought I came back to the original situation),
recognizing the scanner as a 8200 model (generic I suppose).

However, now after rebooting the computer it continues working
only as root and can not access the usb port as a regular user (back as
it was before) for this scanner...

Any hint ?

I've now tried recompiling again and again but still no access as a
regular user... I only I knew what had changed when it was working...

I can send log files if you're insterested.

As a matter of fact (but it may be pointless), though there are lines
like the following in avision.c:

    { "HP",      "C9930A",
      0x03f0, 0x0b01,
      "Hewlett-Packard", "ScanJet 8250",
    /* comment="1 pass, 4800 (?) dpi - USB 2.0" */
    /* status="good" */

    { "HP", "C9930A",
      0x03f0, 0x3905,
      "Hewlett-Packard", "ScanJet 8270",
    /* comment="1 pass, 4800 (?) dpi - USB 2.0" */
    /* status="good" */

    { "HP", "C9930A",
      0x03f0, 0x0b01,
      "Hewlett-Packard", "ScanJet 8290",
    /* comment="1 pass, 4800 (?) dpi - USB 2.0 and SCSI - only SCSI
tested so far" */ /* status="good" */

There is no such thing as:

:model "ScanJet 8270"
:interface "USB"
:usbid "0x03f0" "0x3905"
:comment "1 pass, 4800 (?) dpi - USB 2.0"
:status :good

and only 8250 and 8290 parts are present in avision.desc

Yours sincerely.

> Mike Kelly <mike at piratehaven.org> wrote:
> Hi,
> > I've never had to mess with this stuff, but there are others on the
> > list who have.  This should be easy to fix.  In fact, I believe that
> > there is a file in the source tree which helps udev configure
> > scanners, so you might need to install that.
> The udev rules are generated from the desc files using sane-desc. You
> need to add the scanner to the desc file for avision and it'll appear
> in the udev rules after that.
> JB.

  Olivier Crouzet, PhD
  Laboratoire de Linguistique -- EA3827
  Département de Sciences du Langage
  UFR Lettres et Langages
  Université de Nantes
  Chemin de la Censive du Tertre - BP 81227
  44312 Nantes cedex 3

     phone:        (+33) 02 40 14 14 05 (lab.)
                   (+33) 02 40 14 14 36 (office)
     fax:          (+33) 02 40 14 13 27
     e-mail:       olivier.crouzet at univ-nantes.fr

More information about the sane-devel mailing list