[sane-devel] Troubles with PIXMA MX870 and USB

Stephan Ritscher stephan.ritscher at gmail.com
Mon Jan 31 22:21:25 UTC 2011


I got some more info on the router issue and ADF Duplex. ADF Duplex 
works properly - I just had to set the page count properly or tell the 
client to scan all available pages (e.g. in gscan2pdf). I hadn't tried 
very hard at the time of writing and figured it out later this afternoon 
- sorry for that.

Second info is on the router. Although it was supposed to handle the DNS 
lookup of local ip addresses, it seems it doesn't handle it at all. The 
wrong DNS entries seem to come from my ISP (Vodafone in Germany). I 
"solved" the issue by configuring an external DNS server in my router 
(i.e. the resolv.conf on my computer still is configured to use the 
router as nameserver, but the router acting as DNS proxy gets 
information from an independent DNS server - not the one provided by my 

So, for now the USB connection (not working at all) is the worst issue 
(would be faster then wireless networking, I hope ;-)).


On 31.01.2011 20:31, Louis Lagendijk wrote:
> On Mon, 2011-01-31 at 12:08 +0100, Stephan Ritscher wrote:
>> Hi folks,
>> I just got a new Canon Pixma MX870, but it doesn't work completely,
>> yet.
>> Let me start with my setup. I run Gentoo with kernel 2.6.36-gentoo-r5
>> on an Intel(R) Core(TM)2 Duo CPU T9300. I use the latest sane-backends
>> from GIT and sane-frontends-1.0.14.
>> I want to run the scanner in two different configurations - via
>> wireless network and via usb. I'll start with the wireless setup.
>> First of all, it recognizes my printer - kind of. My router (EasyBox
>> 803) resolves all ip addresses in the local network as "localhost" and
>> thereby confuses SANE.
>>          # /usr/libexec/cups/backend/bjnp
>>          network bjnp://localhost:8611 "Canon MX870 series" "Canon
>>          MX870 series localhost"
>>          "MFG:Canon;CMD:BJL,BJRaster3,BSCCe,NCCe,IVEC,IVECPLI;SOJ:TXT01,BJNP2;MDL:MX870 series;CLS:PRINTER;DES:Canon MX870 series;VER:1.030;STA:10;FSI:04;HRI:EU;MSI:DAT,E3,HFSF;PDR:4;"
>> If I add the line "bjnp://"
>> to /etc/sane.d/pixma.conf, scanimage and other applications recognize
>> my scanner and work properly. I attached the log file corresponding to
>>          # export SANE_DEBUG_PIXMA=3
>>          # scanimage -T 2>  scan-net.log
> This is the second router I have seen that messes up reverse lookup of
> ip-adresses. I will put this on my to-do list to work around this. A
> solution will take some time and will not be in 1.2.22 as the merge
> window for new features has already closed. I will see if I can do the
> change in both the sane backend and in cups-bjnp. I have seen a fritzbox
> return "noname" when a reverse lookup is done, but this one is
> definitely  even more incorrect. Localhost is normally
> your work-around is the correct solution for now.
> I leave your other issue for Nicolas to answer, as he is the maintainer
> of the backend
> kind regards, Louis
> --
> sane-devel mailing list: sane-devel at lists.alioth.debian.org
> http://lists.alioth.debian.org/mailman/listinfo/sane-devel
> Unsubscribe: Send mail with subject "unsubscribe your_password"
>               to sane-devel-request at lists.alioth.debian.org

More information about the sane-devel mailing list