[sane-devel] sane-find-scanner OK but scanimage -L KO

yohann at rebattu.fr yohann at rebattu.fr
Thu Jul 7 20:56:18 UTC 2011

Hello all,
first thank you, you did great work with sane.

then i have a litle problem to make my scanner (lexmark X1150) works with
sane, and more disturbing i can't figure out where things goes wrong.

first as said in documentation i run sane-find-scanner:
found USB scanner (vendor=0x043d, product=0x007c, chip=rts8858c) at
so it looks good.

then i run scanimage -L but it cannot identify my scanner.

Where thing start to get weird is when i'm looking /etc/sane.d/lexmark.conf
i can see the fallowing line:
# X11xx series
usb 0x043d 0x007c

Note that it is the same vendor/product number , it mean my scanner
*should* be identified doesn't it?

one last thing i looked at was:
/etc/sane.d/dll.conf to be sure lexmark was present and it was.

i don't know if it is important but i'm on archlinux amd64 and my sane
version is : 1.0.22.
One last thing: according to this website :
this scanner worked with version 1.0.21 of sane backend.

Yohann Rebattu

PS: as the site said there are somme french in sane people, you'll found
another description of the problem in french here:

PPS: i'm not used to mailing list so forgive me if i'm doing something
wrong, but sane website tell it's ok for sane users to post on sane-devel.

More information about the sane-devel mailing list