[sane-devel] unclear error message

Jeremy Dawson jlcaadawson at netspeed.com.au
Fri Jul 8 12:26:08 UTC 2011

On 07/08/2011 08:12 PM, Olaf Meeuwissen wrote:
> Jeremy Dawson<jlcaadawson at netspeed.com.au>  writes:
>> The equipment is EPSON-Stylus-CX5300 (according to the Printing tool),
>> but I get
>> [jeremy at home2006 ~]$ scanimage -L
>> device `epson2:libusb:003:002' is a Epson CX5400 flatbed scanner
> For SANE backend purposes these are the same.
>> Here is exactly what I did with scanimage:
>> [jeremy at home2006 ~]$ scanimage>image.pnm
>> scanimage: sane_start: Invalid argument
>> [jeremy at home2006 ~]$ scanimage -d epson2:libusb:003:002>image.pnm
>> scanimage: sane_start: Invalid argument
> Not sure whether this is still an issue, but have you tried specifying a
> resolution?  The CX5300 should be able to do 100 but check the output of
> scanimage -h for the `--resolution` option for details.
I tried this - no difference

[jeremy at home2006 ~]$ scanimage >a.pnm
scanimage: sane_start: Invalid argument
[jeremy at home2006 ~]$ scanimage --resolution 100 >b.pnm
scanimage: sane_start: Invalid argument

> There was a time where the default resolution of 300 wasn't checked
> against what the device could actually do.
>> I can't think of any further relevant details but happy to provide
>> them if I know exactly what further details are required
> The out.log file that results from
>    SANE_DEBUG_EPSON2=255 scanimage>  out.pnm 2>  out.log

[jeremy at home2006 ~]$   SANE_DEBUG_EPSON2=255 scanimage > out.pnm 2> out.log
[jeremy at home2006 ~]$ ls -l out.log
-rw-r--r--. 1 jeremy jeremy 39927 Jul  8 22:16 out.log

Output file is attached

> FWIW, Image Scan! for Linux[1] supports this model just fine.  Click the
> All-in-Ones icon and use your browser's find functionality (Ctrl+F ?) to
> locate the CX5300.
>   [1] http://avasys.jp/eng/linux_driver/download/

I'm going away for 2 weeks soon (if I'd known I'd get replies so quickly 
I would have deferred this until I return - thanks for such speedy replies).

I'll try this when I return.

thanks again,


> Hope this helps,

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: out.log
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20110708/02322bb4/attachment-0001.ksh>

More information about the sane-devel mailing list