[sane-devel] sane-find-scanner OK but scanimage -L KO

yohann at rebattu.fr yohann at rebattu.fr
Fri Jul 8 16:39:20 UTC 2011

> Le jeudi 7 juillet 2011 22:56:18 yohann at rebattu.fr, vous avez écrit :
>> Hello all,
>> first thank you, you did great work with sane.
>> then i have a litle problem to make my scanner (lexmark X1150) works
>> with
>> sane, and more disturbing i can't figure out where things goes wrong.
>> first as said in documentation i run sane-find-scanner:
>> found USB scanner (vendor=0x043d, product=0x007c, chip=rts8858c) at
>> libusb:002:006
>> so it looks good.
>> then i run scanimage -L but it cannot identify my scanner.
>> Where thing start to get weird is when i'm looking
>> /etc/sane.d/lexmark.conf
>> i can see the fallowing line:
>> # X11xx series
>> usb 0x043d 0x007c
>> Note that it is the same vendor/product number , it mean my scanner
>> *should* be identified doesn't it?
>> one last thing i looked at was:
>> /etc/sane.d/dll.conf to be sure lexmark was present and it was.
>> i don't know if it is important but i'm on archlinux amd64 and my sane
>> version is : 1.0.22.
>> One last thing: according to this website :
>> http://burogu.makotoworkshop.org/index.php?post/2009/07/14/Backend-Sane-et-
>> Scanner-Lexmark-2- this scanner worked with version 1.0.21 of sane
>> backend.
>> Cheers
>> Yohann Rebattu
>> PS: as the site said there are somme french in sane people, you'll found
>> another description of the problem in french here:
>> http://forums.archlinux.fr/topic8683.html
>> PPS: i'm not used to mailing list so forgive me if i'm doing something
>> wrong, but sane website tell it's ok for sane users to post on
>> sane-devel.
> 	Hello,
> 	there is no 'sane-user' mailing list so this is the right place for such
> reports.
> 	Ca you run scanimage with debug messages so I can have more data on the
> problem you have ? In a command shell do:
> scanimage -L 2>probe.log
> 	then send the probe.log file to the list.
> Regards,
> 	Stef
Thank you for such a quick answer,
The debug info from scanimage -L is attached.
i dont know much about sane, but apparently lexmark driver is loaded but
doesn't recognize my device


-------------- next part --------------
A non-text attachment was scrubbed...
Name: probe.log
Type: text/x-log
Size: 840 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20110708/388b7f1e/attachment.bin>

More information about the sane-devel mailing list