[sane-devel] Scanner DocketPORT 468

Enma Ai jigokunohana at gmail.com
Thu May 26 16:06:32 UTC 2011


I have followed the indications from this site to recompile the backends:

sane-find-scanner -v -v (To identify Id of the vendor, product and chipset)

<device descriptor of 0x1dcc/0x4817 at 002:004 (Document Capture
Technologies Inc. SimpleScan)>
bLength               18
bDescriptorType       1
bcdUSB                2.00
bDeviceClass          255
bDeviceSubClass       255
bDeviceProtocol       255
bMaxPacketSize0       64
*idVendor              0x1DCC
idProduct             0x4817*
bcdDevice             3.02
*iManufacturer         10 (Document Capture Technologies Inc.)
iProduct              11 (SimpleScan)*


<trying to find out which USB chip is used>
    checking for GL84x ...
<This USB chip looks like a *GL842* (result from sane-backends 1.0.21)>
found USB scanner (vendor=0x1dcc [Document Capture Technologies Inc.],
product=0x4817 [SimpleScan], chip=GL842) at libusb:002:004

With the above information I found several possible compatible scanners with
chip GL841, even though this scanner has GL842 and it is not supported.

 /* GL841 devices */
  {0x04a7, 0x0474, &visioneer_xp300_model},
  {0x04a7, 0x0494, &visioneer_roadwarrior_model},
  {0x04a7, 0x049b, &visioneer_xp100_r3_model},
  {0x04a7, 0x04ac, &xerox_travelscanner_model},
  {0x04a9, 0x2213, &canon_lide_50_model},
  {0x04a9, 0x221c, &canon_lide_60_model},
  {0x07b3, 0x0900, &plustek_3600_model},
  {0x0a17, 0x3210, &pentax_dsmobile_600_model},
  {0x04f9, 0x2038, &pentax_dsmobile_600_model}, /* clone, only usb id is
different */
  {0x0a82, 0x4800, &syscan_docketport_485_model},
  {0x0a82, 0x4802, &syscan_docketport_465_model},
  {0x0a82, 0x4803, &syscan_docketport_665_model},
  {0x0a82, 0x480c, &syscan_docketport_685_model},
  {0x1dcc, 0x4810, &dct_docketport_487_model},
  {0x1dcc, 0x4812, &syscan_docketport_467_model},

I have tried with all the docketport and the scanner is recognized only by
those with the same vendor id 0x1dcc:

//Different vendor id (for example 0x0a82, 0x4802,
scanimage -L
    No scanners were identified.

//Same vendor id: 0x1dcc
scanimage -L
    device `genesys:libusb:002:007' is a DCT DocketPORT 487 flatbed scanner

But I get a warning and the scanner finally crashes:

    scanimage >image.pnm
      [genesys] WARNING: Your scanner is not fully supported or at least
      [genesys]          had only limited testing. Please be careful and
      [genesys]          report any failure/success to
      [genesys]          sane-devel at lists.alioth.debian.org. Please provide
as many
      [genesys]          details as possible, e.g. the exact name of your
      [genesys]          scanner and what does (not) work.

Only Docketport 467 worked and it got to scan, however the image was
completely black and when I tried to scan again the scanner wasn't
recognized any longer.

I will do some more tests with this model and I have also contact the
manufacturer just in case they have a linux driver available. If I finally
get it to scan I will post it.

Thanks for your help! :)

On 26 May 2011 17:07, Daniel Elm <delm at bulletscan.com> wrote:

> The scanner should probably work since the backend says it works with the
> Visioneer XP100r3/RoadWarrior/Xerox Travel Scanner, which I believe are
> rebadged versions of the same model.
> *From:* sane-devel-bounces+delm=bulletscan.com at lists.alioth.debian.org[mailto:
> sane-devel-bounces+delm=bulletscan.com at lists.alioth.debian.org] *On Behalf
> Of *Enma Ai
> *Sent:* Thursday, May 26, 2011 4:44 AM
> *To:* sane-devel at lists.alioth.debian.org
> *Subject:* [sane-devel] Scanner DocketPORT 468
> Hi,
> I'm trying to get to work scanner DocketPORT 468.
> I already know it is not supported and I have found no discussions related,
> however I'm giving it a try as the  genesys  backend  provides  support for
> scanners based on the Genesys Logic GL646 and GL841 chips and I have read in
> a discussion that GL842 is essentially the same as the GL841.
> My OS is: Linux version 2.6.35-28-generic (buildd at rothera) (gcc version
> 4.4.5 (Ubuntu/Linaro 4.4.4-14ubuntu5) )
> I have (sane-backends) 1.0.21; backend version 1.0.21.
> When connecting the scanner I get:
> :dmesg
> [ 3960.456090] usb 2-5: new high speed USB device using ehci_hcd and
> address 9
> :sane-find-scanner -v
> found USB scanner (vendor=0x1dcc [Document Capture Technologies Inc.],
> product=0x4817 [SimpleScan], chip=GL842) at libusb:002:008
> :scanimage -V
> scanimage (sane-backends) 1.0.21; backend version 1.0.21
> But:
> scanimage -L
> No scanners were identified.
> Any suggestions? Should I just forget about it and look for another
> scanner? :)
> Thanks and regards
> Enma :)

* La Niña Ninja *
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20110526/c1ecd7c5/attachment.html>

More information about the sane-devel mailing list