[sane-devel] Canon Pixma MX375 problems with SANE

Daniel Lehmann mail at fototux.com
Thu Aug 23 02:22:17 UTC 2012

In short: it works rudimentary with commandline tool, but gives an error 
with XSANE.


I tried to get a new Canon Pixma MX375 working on my Ubuntu 12.04 64-bit 
sytem. Because of the need of the pixma-backend in version 0.17.0 I 
installed SANE 1.0.23 from git.

The command
gives following output:
"found USB scanner (vendor=0x04a9, product=0x1759) at libusb:002:011"

$scanimage -L
is telling
"device `pixma:04A91759' is a CANON Canon PIXMA MX370 Series 
multi-function peripheral"

So I activated debuging modes and experimental backend ($export 
SANE_DEBUG_PIXMA=21 && export SANE_DEBUG=255 && export 
SANE_DEBUG_SANEI_USB=255 && export PIXMA_EXPERIMENT=1) and tried the 
following command
$scanimage -T > /tmp/logfile
this results in a big amount of textoutput and seems to work.

$scanimage > test.pnm
works and creates a correct Image from the flatbed part of the scanner 
(it also has an ADF). But if I start XSANE there is an error message 
that the communication did not work. It says (translated german error code)
"Error opening device 'pixma:04A91759_1063CB': Operation not supported"

If I list the avaliable devices with

$scanimage -f
this results in

[pixma] scanner discovery finished...
[pixma] WARNING:Experimental backend CAN DAMAGE your hardware!
[pixma] pixma_open(): Canon PIXMA MX370 Series
[sanei_usb] sanei_usb_open: trying to open device `libusb:002:006'
USB error: could not set config 1: Device or resource busy
[sanei_usb] sanei_usb_open: libusb complained: could not set config 1: 
Device or resource busy
[sanei_usb] Maybe the kernel scanner driver or usblp claims the 
interface? Ignoring this error...

Has anybody an idea how to solve this problem? Any help would be 
appreciated :)


More information about the sane-devel mailing list