[sane-devel] genesys backend - plustek opticbook 3600 pro - i'm having problems (online images)

niky 45 niky.el45 at gmail.com
Tue Dec 11 10:13:56 UTC 2012

so, i need to make this scan work for my library project. but it is giving
me so many problems.
i'll attach you what it does, and the original image.
http://ompldr.org/vZ25mdw (note it's converted to jpg so you can see it
online. te commandline was *convert -quality 70 001.pnm 001.jpg*)

console output: ------------------------------------------
 >>> scanimage -d genesys:libusb:002:003 --mode Color --format pnm
--swcrop=yes --resolution 200 -v >001.pnm
[genesys] WARNING: Your scanner is not fully supported or at least
[genesys]          had only limited testing. Please be careful and
[genesys]          report any failure/success to
[genesys]          sane-devel at lists.alioth.debian.org. Please provide as
[genesys]          details as possible, e.g. the exact name of your
[genesys]          scanner and what does (not) work.
scanimage: scanning image of size 1622x2337 pixels at 24 bits/pixel
scanimage: acquiring RGB frame
scanimage: min/max graylevel value = 0/255
scanimage: read 11371842 bytes in total

and the second one is a (low quality) photo of it (taken with my cell
phone). keep in mind it gives very little contrast - the light part is
actually white.

i have been looking around, and i found that channels are screwed up. i
mean, if you open the scanned image with gimp, and separate the channels,
you can see the red one is OK, but blue and green are not good. i mean, too
many lights and shadows.  (i can show you another image if it's not clear
with this one)

i have two of those scanners, and both of them do the same thing. i have
tried with several computers, and got same results. however, with other
scanners, scanimage works fine. the same aplies for xsane.

i don't mind getting my hands into the driver (genesys_gl841), BUT, i don't
know how to use usbsnoopy under windows (i tried, but it did nothing), and
even if it worked, i wouldn't know what to do with that data.

also, i found this:
but i understood very little if anything.

so, i need to get this scanner working, driver is doing weird things (under
windows, scanners work as expected), and i don't know what to do with it.

PS: i tried to activate debugging, but scanimage wouldn't  accept a --debug
option, and setting just the debug vars did nothing (SANE_DEBUG=255 and so
on). i also tried to recompile the driver to activate debug support (i'm
working with packages from debian wheezy's repos), but it told me this:
[10:56:12] - [root at vivo:/usr/src/sane-backends-1.0.22]
713 >>> command ls -F
acinclude.m4      ChangeLog-1.0.14  ChangeLog-1.0.4  configure*
japi/           po/             README.linux       sanei/
aclocal.m4        ChangeLog-1.0.15  ChangeLog-1.0.5  configure.in
lib/            PROBLEMS        README.netbsd      testsuite/
AUTHORS           ChangeLog-1.0.16  ChangeLog-1.0.6  COPYING
LICENSE         PROJECTS        README.openbsd     tools/
backend/          ChangeLog-1.0.17  ChangeLog-1.0.7  debian/
ltmain.sh*      README          README.os2
ChangeLog         ChangeLog-1.0.18  ChangeLog-1.0.8  depcomp*
m4/             README.aix      README.solaris
ChangeLog-1.0.0   ChangeLog-1.0.19  ChangeLog-1.0.9  doc/
Makefile.am     README.beos     README.unixware2
ChangeLog-1.0.1   ChangeLog-1.0.2   compile*         frontend/
Makefile.in     README.darwin   README.unixware7
ChangeLog-1.0.10  ChangeLog-1.0.20  config.guess*    include/
missing*        README.djpeg    README.windows
ChangeLog-1.0.12  ChangeLog-1.0.21  config.log       INSTALL
mkinstalldirs*  README.freebsd  README.zeta
ChangeLog-1.0.13  ChangeLog-1.0.3   config.sub*      install-sh*
NEWS            README.hp-ux    sane-backends.lsm

[10:56:28] - [root at vivo:/usr/src/sane-backends-1.0.22]
714 >>> . configure
bash: WARNING: you should use --build, --host, --target
bash: WARNING: you should use --build, --host, --target
bash: error: cannot find install-sh, install.sh, or shtool in "/bin"
"/bin/.." "/bin/../.."
i have installed build deps through aptitude.

PS2: i know my english is not perfect. sorry for that. i  really do what i

>> niky45 <<

>> niky45 <<
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20121211/6d20345d/attachment.html>

More information about the sane-devel mailing list