[sane-devel] HP 2300c scan problem with SANE USB

Nils Nebe knillbert at gmail.com
Wed Feb 8 14:12:52 UTC 2012

Hey there,

I'm trying to scan material with a HP scanjet 2300c scanner on my MAC OSX
1.6 system. I have already downloaded the full SANE package that you
provide on your homepage and installed it successfully. The SANE connection
shows up in all different scan softwares I've tried (Image Capture,
Photoshop CS5, Exact Scan). Only in GraphicConverter it is not recognized
at all. Now the problem is, the actual scan won't work, it's only loading
previews or scans, but does not transfer the data. Only one exception:
I have checked the Backend ID and made a successful (!) test scan in
Terminal by using: scanimage > test.pnm AND scanimage --format tiff >
The fact, that it scanned a tiff file perfectly through Terminal, tells me
that there should be a way to make it work with a more handy software also,

About the set up:
The scanner is connected to power and through USB to the Mac.

I checked my scanner in Terminal by

scanimage -L

and got the following results..



  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x03f0 [Hewlett-Packard], product=0x0901 [hp
scanjet scanner], chip=GL646?) at libusb:002:002-03f0-0901-00-00
found USB scanner (vendor=0x05ac [Apple Inc.], product=0x8215 [Bluetooth
USB Host Controller]) at libusb:003:003-05ac-8215-ff-01
  # Your USB scanner was (probably) detected. It may or may not be
supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

  # You may want to run this program as root to find all devices. Once you
  # found the scanner devices, be sure to adjust access permissions as
  # necessary.
PostProduction:~ mladenvulovic$ scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
PostProduction:~ mladenvulovic$


As you can see it first recognises the scanner (1st command) and then not
(2nd command). But yesterday it already confirmed both of these commands
and still did not work with any scan software.
I also tried all of the rest suggestions on your faq site
Nothing worked.
Now with Exact Scan it recognised the SANE connection, but once it came to
starting the scan it just loads without getting anywhere with it.

Would you please be able to advise me in this case. I expect, I might not
be the only one with this problem, as this printer (HP 2300c) seems to be
used by quite a few still.
I would be glad to hear from you soon.

Many thanks,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20120208/1a1a1502/attachment.html>

More information about the sane-devel mailing list