[sane-devel] Network backend and lineart mode

Stef stef.dev at free.fr
Mon Jul 30 19:08:27 UTC 2012

On 30/07/2012 12:47, Aleksandr Dezhin wrote:
> On 07/29/2012 10:35 AM, stef wrote:
>> Le 29/07/2012 08:22, Aleksandr Dezhin a écrit :
>>> On 07/28/2012 12:46 PM, Stef wrote:
>>>> On 27/07/2012 23:25, Aleksandr Dezhin wrote:
>>>>> Dear developers,
>>>>> I am trying to develop another web-based interface for sane. Faced 
>>>>> with a problem, and do not know how to avoid it or solve it.
>>>>> I have Canon LiDE 210 scanner, it works fine with genesys backend. 
>>>>> Locally scanimage works in all modes: color, gray, lineart. 
>>>>> However, if I scan through the network using net backend, it stops 
>>>>> work in lineart mode.
>>>>> Scanimage freezes, until I kill the process. I attached stderr of 
>>>>> scanimage --mode Lineart with SANE_DEBUG_NET=9. Process freezes 
>>>>> after "[net] sane_read: reading packet length", "scanimage: 
>>>>> received signal 15" appears after killall scanimage.
>>>>> Unfortunately I can not check whose problem it is: genesys or net 
>>>>> backends. Test backend does not support lineart mode.
>>>>> Has anyone encountered a similar problem? How can I try solve it?
>>>>> Thanks.
>>>>     Hello,
>>>>     what would be handy to solve this issue, would be to run saned 
>>>> with SANE_DEBUG_GENESYS environment varaible set to 255, and get 
>>>> the debug messages. This way, I'll have the scan parameters given 
>>>> to the genesys backend in order to test this here.
>>>>     You may try to play with 'emulated lineart' option.
>>>>     And last, what is your SANE version ? It doesn't show up in the 
>>>> log file.
>>>> Regards,
>>>>     Stef
>>> SANE version is 1.0.22, device connected to 32-bit OS Thinstation 
>>> 5.1 (sane build from sources), client where I strart scanimage - 
>>> 64-bit Ubuntu 12.04. Results SANE_DEBUG_GENESYS I'll send - as soon 
>>> as I get to the device. By the way, is there a simple way to capture 
>>> stderr, if saned used together with xinetd? Today I tried the same 
>>> (but both 64-bit Ubuntu)  thing with a another scanner (HPLIP 
>>> backend) - lineart mode works. 
>>     Hello,
>>     I expect saned is exposing a bug in the genesys backend for the 
>> settings you use, surely some issue with the amount of bytes to send. 
>> I remember fixing such a bug for lide100/200 after 1.0.22 release, 
>> but this may be another one. 
> Seems I should try trunk version.
>> Test with emulated lineart disabled.
> Yes, it works with --disable-dynamic-lineart=yes
>> Using a wrapper script (redirecting stderr to file) could be enough, 
>> and telling xinetd to use it instead of the current program.
> Wrapper script for some reason does not work. A feeling that saned 
> ignores the environment variables. But I ran it in standalone mode :)
> Log attached.
>> Regards,
>>     Stef

     I cannot reproduce your bug running directly scanimage with the 
same parameters than you :
scanimage -d genesys --resolution 75 --width 213.2 --mode Lineart 
2>rl.log >rl.pnm

     I am now going to set up saned.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20120730/a62ac575/attachment-0001.html>

More information about the sane-devel mailing list