[sane-devel] Canon LiDe 210 Genesys backend gone wrong

Jay Christnach jay.christnach at gmx.net
Fri Jun 15 15:03:14 UTC 2012

Hi Armin,

I now tested with everything else removed from my usb ports except my 
keyboard/mouse wireless receiver. I used one of the hubs that are 
directly on the motherboard. It didn't work.

Here some considerations why I think (thought) that it isn't (wasn't) a 
hardware issue:

- The scanner worked everytime a year ago on this machine (don't know 
which hub I used though).

- The scanner works on the same host with the same cable on the same hub 
when I use it in an XP virtual machine with this xubuntu system as host OS.

-The cable I use works with my  smart phone to charge it (high current) 
and to transfer data.

This is getting a bit weird now. I thought it stopped working on my 
laptop (Ubuntu 11.04) too, because I had the no lamp problem there once. 
Now I rechecked while writing this e-mail just to be sure and it worked 

I wrote a log file on the laptop and discovered that the sane genesys 
backend is the same there: build 63 from sane-backends 1.0.22 .

I used the same cable on the laptop than before on the desktop. Ok, now 
I don't trust the cable or the scanner anymore. Maybe there is a bad 
soldering on the connector on the pcb? But why would the data get passed 
and the stepping motors work if there are no 5 Volts and the data 
connections? Could the current get delivered by the data inputs 
sometimes? (no, this would be an USB-uncompatible design problem)

What we now know is that it isn't an issue with sane, rather something 
with USB power configuration or an electromechanic issue (unlikely). 
I'll test some other things; another cable, the scanner on another 
machine, maybe low-level usb monitoring if I'm able to do that.

Thanks for your help. I will send you an e-mail if I discover something 


On 06/14/2012 10:58 PM, Armin Stebich wrote:
> Hi,
> I got my LiDE 210 successfully running after having the same problem.
> The scanner worked correct on my Laptop with Ubuntu 11.10 32-Bit and
> SANE 1.0.22. On my new Desktop under 12.04 64-Bit and SANE 1.0.22 I got
> only black scans. The scanner bar moves but the LED's remained dark.
> I switched to SANE 1.0.23.git with the same result, only black scans.
> Switched back to 1.0.22 I took logs from both machines and found no
> significant differences.
> In the end I found the problem in the USB ports. On the front panel USB
> 1.1/2.0 Port the scanner produces the black scans. Connecting the
> scanner to a backside USB 3.0 port the scanner works perfectly.
> So I think this is not a software problem. The scanners power
> consumption is 500mA which must be delivered from the USB port. The
> scanner has no external power supply. Because of new green technologies
> it it possible, that not all USB port deliver this maximum current.
> Because my scanner is working with the backside USB port I didn't
> examine how to get it running on the front panel USB port. Maybe this is
> a matter of mainboard settings or there are any system or kernel
> parameters to allow the high power consumption on the port.
> Another solution could be an USB Hub with external power supply, but
> this is only a assumption without guarantee.
> If I can test something, please let me know.
> Best regards.
> Am 14.06.2012 21:09, schrieb stef:
>> Le 14/06/2012 11:16, Jay Christnach a écrit :
>>> Thanks for the quick reply, Stef.
>>> To remind the other people who may read this: The symptom is that the
>>> led array of the scanner doesn't turn on, although the scanning
>>> assembly does the normal movement scanning the page.
>>> Attached is the stderr from xsane while having the environment
>>> variables set as you said.
>>> best regards.
>>> On 06/13/2012 09:39 PM, stef wrote:
>>>> In order to find where your problem comes from, you could run your
>>>> frontend like simple-scan, xsane or scanimage with debug messages
>>>> enabled. In a command shell type (provided you are using xsane):
>>>> export SANE_DEBUG_GENESYS=255
>>>> export SANE_DEBUG_GENESYS_LOW=255
>>>> export SANE_DEBUG_GENESYS_GL847=255
>>>> xsane 2>debug.log
>>>> Then the debug.log file will contain messages that should help find
>>>> what is happening.
>>>> Regards,
>>>>           Stef
>>      Hello,
>>      unfortunately, there is nothing obvious in the log. The version
>> running is build 63 from SANE 1.0.22. The genesys backend has been
>> improved recently. It would be great if you could test this new version
>> that will part of the 1.0.23 release which is due in a couple of months.
>> Regards,
>>      Stef

More information about the sane-devel mailing list