[sane-devel] HP Scanjet 5370c scanner. Reports "no devices available."

Mike Kelly mike at piratehaven.org
Sun Mar 25 22:25:36 UTC 2012

Hi Bob,

I've just committed some changes to the code repository which will
probably fix your problems with this scanner.

Please compile the latest code and let me know if you still have any


On Sat, Feb 18, 2012 at 04:35:34AM -0500, Bob Goodwin wrote:
>    I'm having an unexpected problem with xsane in two new installs of
>    Fedora-16/64 bit.
>    I have not had much luck with suggestions from the Fedora list so
>    will repeat some of that material here.
>    I'm not sure if it's a matter of the right driver not being
>    available or if the old scanner has chosen this time to fail.
>        This is a new install F-16/64 recently updated. Xsane is unable to
>            detect the HP Scanjet 5370c scanner. Reports "no devices
>        available."
>            It appears to be detected as a USB device:
>                [bobg at box6 ~]$ lsusb
>                Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0
>        root hub
>                Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1
>        root hub
>                Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1
>        root hub
>                Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1
>        root hub
>                Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1
>        root hub
>                Bus 002 Device 002: ID 046d:c408 Logitech, Inc. Marble
>        Mouse
>                (4-button)
>                Bus 002 Device 003: ID 03f0:0701 Hewlett-Packard ScanJet
>        5300c/5370c
>            I do not usually have trouble getting this scanner working,
>        normally
>            just yum install xsane and it's ready to go. Not so today
>        however
>            and of course I needed it working half an hour ago!
>            Need help troubleshooting.
>            I've installed all I can find under xsane and scanner
>        drivers in
>            yumex and still get "no device available" on both F-16/64
>        computers.
>            I installed xsane on the second computer just to be sure
>        it's not
>            peculiar to this one.
>            And I tried running as root as suggested, it produces a
>            warning not to, doing it anyway yields the same result, no
>            device available
>            I suppose the scanner could have failed but it was working
>            recently with F-15.
>            Am I the only one unable to run an HP scanner on Fedora-16? My
>            installs are from a live USB/xfce version but I have been
>        doing it
>            that way for some time without any problems.
>    I guess what I need to know is what driver is required for the
>    HP-5370 scanner and if it is available in Fedora-16 and how to
>    troubleshoot the problem. In recent years xsane has always just
>    worked and I have given it little thought which I guess is a sort of
>    compliment to the developers.
>    Any suggestions appreciated.
>    Bob
> -- 
> sane-devel mailing list: sane-devel at lists.alioth.debian.org
> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
> Unsubscribe: Send mail with subject "unsubscribe your_password"
>             to sane-devel-request at lists.alioth.debian.org

--------Mike at PirateHaven.org-----------------------The_glass_is_too_big--------

More information about the sane-devel mailing list