[sane-devel] Canoscan LiDE 30 getting stuck on usbio_DetectLM983x

Serge Klink sgklink at gmail.com
Fri Apr 12 09:31:59 UTC 2013

On 2013-04-12 17:41, Gerhard Jäger wrote:


>> Now, if I plug it in, start VirtualBox/WinXP, let it take
>> over/initialize the scanner, THEN repeat:
> [...]
> Could you be more precise. Do you simply start the VirtualBox, or do
> you start also inside the CanoScan device driver or similar?


It's a 32-bit WinXP virtual machine with Canon's drivers installed
inside, running on a 64-bit Linux (Debian Wheezy) host.

The procedure is:

1. Plug in the scanner (physically).
(Scanner is recognized by the host Linux kernel. No external signs of
life - lamp does not turn on, motor does not move, etc.)

2. Run scanimage -L (on the host).
(Still no signs of life, error on usbio_DetectLM983x)

3. Start VBox, boot up the virtual machine normally.

4. Connect the scanner to the virtual machine (from Virtualbox's menu).
(Scanner starts moving, calibrating (?) itself, etc.)

5. Disconnect the scanner from the virtual machine (but leave it
connected physically to the host), power the VM down.

6. Run scanimage -L again (on the host).
(Finds the scanner quickly, no errors.)

Also tried installing 32-bit libsane and sane-utils (1.0.22 from the
i386 repo) - no difference.  Haven't tried it with a full 32-bit
system yet.

More information about the sane-devel mailing list