[sane-devel] Epson2 backend and ADF

Michael Koltan koltan at gmx.de
Fri Aug 2 12:58:58 UTC 2013

This is a lot more work than I thought. I had the backend working 
perfectly right. But after rebooting, the scanner did constantly hang 
after sending the feed command (0x16) and then requesting the extended 
status (ESC-f). Has somebody a suggestion what the cause of this may be?

As to the questions of Olaf: I upgraded in two steps, first from from 
lenny to squeeze. I compiled iscan-2.29.1 with the epkowa backend 1.0.15 
in squeeze. The compilation worked, although some test failed. But the 
backend then produced an errormessage which I don't have anymore, but I 
think it was the same as on wheezy (see below).

After that I decided just to upgrade to wheezy and check, if the newest 
epson2 driver would be working. It didn't. The I recompiled iscan, but 
the backend gives the errormessage: "scanimage: open of device epkowa 
failed: Access to resource has been denied".

Then I decided to fix the epson2 backend instead of the epkowa backend, 
because alread on lenny the epkowa backend didn't work 100% correctly. 
Duplex worked fine, but there was a problem when scanning simplex (I 
don't remember what it was, but I think it didn't scan the last sheet). 
So on lenny I had to switch between 1.0.15 and 1.0.19 of the epkowa 
driver for simplex respective duplex, because the 1.0.19 backend failed 
on duplex.

I'll try again on the weekend to fix the epson2 driver - I think I miss 
just one tiny bit of the puzzle...


Michael Koltan
Schongauerweg 61
79110 Freiburg
0761 / 76 78 033

More information about the sane-devel mailing list