[sane-devel] Epson2 backend and ADF

Olaf Meeuwissen olaf.meeuwissen at avasys.jp
Sat Aug 3 03:28:16 UTC 2013

Olaf Meeuwissen writes:

> Michael Koltan writes:
>> [...]
>> As to the questions of Olaf: I upgraded in two steps, first from from 
>> lenny to squeeze. I compiled iscan-2.29.1 with the epkowa backend 1.0.15 
>> in squeeze. The compilation worked, although some test failed. But the 
>> backend then produced an errormessage which I don't have anymore, but I 
>> think it was the same as on wheezy (see below).
>> After that I decided just to upgrade to wheezy and check, if the newest 
>> epson2 driver would be working. It didn't. The I recompiled iscan, but 
>> the backend gives the errormessage: "scanimage: open of device epkowa 
>> failed: Access to resource has been denied".

I checked the epkowa backend sources and it only returns the "Access to
resource has been denied" status if the backend has not been initialized
or if it cannot find any supported device.  This makes me think that
this message is courtesy of the dll backend rather than the epkowa one.
I suspect that you installed the backend somewhere the dll backend does
not look.  Could you provide the scanimage.log generated by the command
below so I can confirm?  Feel free to analyze it yourself, BTW :-)

  SANE_DEBUG_DLL=128 SANE_DEBUG_EPKOWA=HEX scanimage > /dev/null 2> scanimage.log

>> Then I decided to fix the epson2 backend instead of the epkowa backend, 
>> because alread on lenny the epkowa backend didn't work 100% correctly. 
>> Duplex worked fine, but there was a problem when scanning simplex (I 
>> don't remember what it was, but I think it didn't scan the last sheet). 
>> So on lenny I had to switch between 1.0.15 and 1.0.19 of the epkowa 
>> driver for simplex respective duplex, because the 1.0.19 backend failed 
>> on duplex.
> Sounds like you are compiling the iscan package from source.  I think
> you will have more luck with the precompiled binaries as there are a
> number of things that need to be done after
>   sudo make install
> that the binary packages will do for you in the post-install phase.
> Also, you will need to install the iscan-data package.
> Precompiled binaries are available from:
>   http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX

I tried to check the versions but didn't get any search results for the
GT-10000+.  Search for the ES-6000H which is the name this model is
marketed under in Japan (as per SANE supported devices info[1]).  Latest
packages are iscan-2.29.1 and iscan-data-1.23.0.

 [1] http://sane.alioth.debian.org/lists/sane-backends-external.html#S-EPKOWA

Hope this helps,
Olaf Meeuwissen, LPIC-2           FLOSS Engineer -- AVASYS CORPORATION
FSF Associate Member #1962               Help support software freedom

More information about the sane-devel mailing list