[sane-devel] scanbd daemon does not load firmware

Ilya V. Ivanchenko iva2k at yahoo.com
Thu Aug 29 13:25:41 UTC 2013

Hi Wilhelm,

>is there a special reason using the (old) scanbuttond-backends and not 

I first tried sane-backends, and apparently it does not read the buttons for Epson GT-1500. I tried various things with sane-backends, but "scanimage -A" gives no button options and it was very unclear how to patch sane-backends or even where to start. So I quickly gave up and moved to scanbuttond-backends where it was easy to figure out a patch and it worked right away. I'd be glad if sane backend worked, but even Epson's iscan does not support buttons (seemingly on any of their scanners).

>If you plugin / poweron the scanner for the first time, who does the 
>firmware get loaded in this case?
Good question. Now retracing my steps backwards, I think I got iscan+sane to load the drivers the very first time and I did not notice this problem. When I tested things, I always used "scanimage -L" as a quick test, and it pulled the string up to the firmware loading (at which moment scanner clearly does a whizz sound moving the head in its POST). It appears to me that scanbd somehow misses calling the firmware load on USB insert (before reading buttons), but does it on scanimage -L. Perhaps it is due to the use of scanbuttond-backends and not sane-backends.

So my current conclusions are that there are two potential issues to fix:
 1. Make sane-backends support buttons that scanbuttond-backends support.
 2. When using scanbuttond-backends, fix loading firmware on USB insert.
Please correct me if I'm wrong here.

w.meier at unix.net
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20130829/c1035439/attachment.html>

More information about the sane-devel mailing list