[sane-devel] scanbd daemon does not load firmware

Ilya V. Ivanchenko iva2k at yahoo.com
Thu Aug 29 13:52:43 UTC 2013

Hi Wilhelm,

>>> is there a special reason using the (old) scanbuttond-backends and not

>> I first tried sane-backends, and apparently it does not read the buttons
>> for Epson GT-1500.
>did you use the epkowa backend? The sane-support-page says, that this 
>backend supports most features of the GT-1500.
Yes, epkowa is the backend used in the current configuration. I had problems of getting buttons to work with sane, but now retracing back it may be due to sane configuration needing epson2 (would not work with epkowa for some reason), and switching to scanbd needing epkowa (would not work with epson2).

I just tried "scanimage -A" again and found "--monitor-button" option there, but "scanimage -h" does not have button options (except --wait-for-button). Can you suggest what commands I should use to test the buttons from command line?

>> So my current conclusions are that there are two potential issues to fix:
>>   1. Make sane-backends support buttons that scanbuttond-backends support.
>that would be the best choice, since I have no real plans to support the 
>scanbuttond backends.
I guess I could try sane-backends again to see if I can make the buttons work with epkowa backend.

>>   2. When using scanbuttond-backends, fix loading firmware on USB insert.
>what I could imagine is to fix this problem with a special 
>shell-callback, when scanbd detects a device inserion / removal.
This is in the nutshell how I patched the problem from udev.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20130829/780263cb/attachment.html>

More information about the sane-devel mailing list