[sane-devel] obtaining sane-recognised driver for Samsung mfp-3400

Tamás Rébeli-Szabó tamas.rebeli.szabo at gmail.com
Mon Jan 14 14:04:17 UTC 2013

Hello Julien,

thank you for your email.

I have actually tried installing different versions of the Samsung
Unified Driver, including the one you have used.

I have a 64-bit architecture, Qt4 is installed, the GUI installer
works (the uninstaller doesn't, however).

The GUI installer tells me that it cannot find the SANE API, but I
suspect this is distribution-specific issue, as SANE API is installed
(unless there is some magic package with a totally different name...).
I can choose to proceed with the installation without SANE, so I did
just that.

Now, in Samsung Configurator, when I select scanners, it says there is
no scanner is present.

I also tried suldr's repository, to no avail.

Would you mind running these commands *as root* and sending me the
samsung_scx_3400.txt file? These commands only collect scanner related
information, nothing more.

echo "~*~*~*~*~*~*~* samsung usb devices ~*~*~*~*~*~*~*" > samsung_scx_3400.txt
lsusb | grep "04e8" >> samsung_scx_3400.txt
echo -e "\n\n~*~*~*~*~*~*~* sane version  ~*~*~*~*~*~*~*" >>
scanimage --version >> samsung_scx_3400.txt
echo -e "\n\n~*~*~*~*~*~*~* sane-find-scanner  ~*~*~*~*~*~*~*" >>
sane-find-scanner -vv >> samsung_scx_3400.txt
echo -e "\n\n~*~*~*~*~*~*~* scanimage list  ~*~*~*~*~*~*~*" >>
scanimage -v -L >> samsung_scx_3400.txt
echo -e "\n\n~*~*~*~*~*~*~* kernel modules  ~*~*~*~*~*~*~*" >>
lsmod | grep -E "xerox|mfp|usb" >> samsung_scx_3400.txt
echo -e "\n\n~*~*~*~*~*~*~*  xerox_mfp.conf  ~*~*~*~*~*~*~*" >>
grep -C 2 "04e8" /etc/sane.d/xerox_mfp.conf >> samsung_scx_3400.txt
echo -e "\n\n~*~*~*~*~*~*~*  udev rules in /etc  ~*~*~*~*~*~*~*" >>
grep -H -C 2 "04e8" /etc/udev/rules.d/*.rules >> samsung_scx_3400.txt
echo -e "\n\n~*~*~*~*~*~*~*  udev rules  in /lib ~*~*~*~*~*~*~*" >>
grep -H -C 2 "04e8" /lib/udev/rules.d/*.rules >> samsung_scx_3400.txt

Thanks for your help in advance.

Kind regards,

2013/1/12 michkloo <michkloo at xs4all.nl>:
> Tamás Rébeli-Szabó schreef op 2013-01-12 10:49:
>> Hello Michkloo,
>> I have a Samsung SCX-3400F on Ubuntu 12.10. It is not recognized by SANE.
>> Others also report success with SCX-3400, and that has the same USB Id
>> as SCX-3400F.
>> How did you exactly 'compile' Samsung UnifiedLinuxDriver_1.01.tar.gz?
>> To me, that tar seems to contain a binary installer which is
>> downloadable from the Samsung Support website as a 'Print Driver'.
>> Samsung Support told me in an e-mail that there is currently only a
>> driver for the printer. There is, however, a libsane-smfp.so.1.0.1
>> library in it, which to me seems as the custom scanner driver from
>> Samsung.
>> I am confused. Your help would be very much appreciated.
>> Kind regards,
>> tamas
> I don't think I did do anything special: first I untarred
> UnifiedLinuxDriver.
> I'm not entirely sure what I did after. Quite a few weeks passed since.
> However: I created a UnifiedLinuxDriver-directory, and untarred
> UnifiedLinuxDriver.tar in it.  This creates a cdroot-directory.
> I think my next step was execution of
> local/UnifiedLinuxDriver/cdroot/Linux/i386/qt4/install/guiinstall
> And unless I'm mistaken, this did the trick.  Your mile-age may very:
> I don't know if you have i386 architecture, and if you installed qt4,
> but I think this is what I did.  Please reply whether this worked for
> you.
> Julien

More information about the sane-devel mailing list