[sane-devel] Canon LiDE 700F flatbed scanner

Stef stef.dev at free.fr
Fri Jun 7 04:15:28 UTC 2013

On 06/06/2013 22:51, Sven Steckmann wrote:
> Hi Stef,
> I read your post on the sane-devel mailinglist and found no reply on 
> your request about a debug log. I also have a Canon Lide 700F scanner, 
> which has been detected, but I am unable to scan (Ubuntu 12.04 too).
> Doing a sane-find scanner works, scanning failed:
> sven at sven-Latitude-E5420:~$ sudo sane-find-scanner
>   # sane-find-scanner will now attempt to detect your scanner. If the
>   # result is different from what you expected, first make sure your
>   # scanner is powered up and properly connected to your computer.
>   # No SCSI scanners found. If you expected something different, make 
> sure that
>   # you have loaded a kernel SCSI driver for your SCSI adapter.
> found USB scanner (vendor=0x04a9 [Canon], product=0x1907 [CanoScan], 
> chip=GL847) at libusb:002:006
>   # Your USB scanner was (probably) detected. It may or may not be 
> supported by
>   # SANE. Try scanimage -L and read the backend's manpage.
>   # Not checking for parallel port scanners.
>   # Most Scanners connected to the parallel port or other proprietary 
> ports
>   # can't be detected by this program.
> As you wrote in the mailing, I did now the following:
> shell and exporting the environments variables:
> export SANE_DEBUG_GENESYS_GL646=255
> export SANE_DEBUG_GENESYS_GL841=255
> export SANE_DEBUG_GENESYS_GL843=255
> export SANE_DEBUG_GENESYS_GL847=255
> export SANE_DEBUG_GENESYS_GL124=255
> xsane 2>debug.log
> and sent you the debug.log attached to this mail. Maybe, you can have 
> a look at it. Thanks for your work :)
> Kind regards,
>    Sven

     USB is failing to work properly, no more 'device' after several 
successful USB I/O:

     [sanei_usb] sanei_usb_control_msg: rtype = 0xc0, req = 4, value = 
142, index = 16674, len = 2
USB error: error sending control message: No such device
[sanei_usb] sanei_usb_control_msg: libusb complained: error sending 
control message: No such device
[genesys_low] sanei_genesys_read_gl847_register (0x41): failed while 
setting register: Invalid argument
[genesys_gl847] gl847_slow_back_home: failed to read home sensor: 
Invalid argument
[genesys] sane_exit: start

     If you have USB3, plug the scanner in a USB2.0/1.1 port, I have 
reports where it solved similar problem. Another thing to test is to 
disable USB power management, which also solved this problem for several 
users including me.


More information about the sane-devel mailing list