[sane-devel] Fujitsu ScanSnap ix500 supported?

VK list-sane-devel at kutty.cc
Fri Mar 1 05:12:06 UTC 2013

m. allan noah <kitno455 <at> gmail.com> writes:

> I have just committed an updated version (113) of the fujitsu backend
> to our git repo. You can get a current git checkout of sane-backends,
> or you can wait until tomorrow and download one of our git snapshots:
> http://www.sane-project.org/source.html
> This updated provides initial support for the iX500. So far this is
> color mode only. I have not yet managed to make the thing scan in
> binary or gray.
> Please try it out and let me know if you find any problems with color scans.
> allan


I tried git snapshots 20130227 and 20130228 on Fedora 18. I've never really had
to play with SANE before, so I'm ignorant of the architecture. I think I have it
built right, but I did install to its own tree under /opt/sane/backends/...

First, sane-find-scanner found it.

Then I ran 'scanimage -L' and it SEGV'd:

# gdb ./scanimage ./core.7423 
GNU gdb (GDB) Fedora (7.5.1-36.fc18)
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
Reading symbols from /opt/sane/backends/20130228/bin/scanimage...done.
[New LWP 7423]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Core was generated by `./scanimage -L'.
Program terminated with signal 11, Segmentation fault.
#0  __strcmp_sse42 () at ../sysdeps/x86_64/multiarch/strcmp-sse42.S:162
162		movdqu	(%rdi), %xmm1
(gdb) bt
#0  __strcmp_sse42 () at ../sysdeps/x86_64/multiarch/strcmp-sse42.S:162
#1  0x00007f12b6cf1be5 in store_device (device=...) at sanei_usb.c:344
#2  0x00007f12b6cf2599 in sanei_usb_init () at sanei_usb.c:674
#3  0x00007f12b03a4481 in sane_epson2_init (version_code=0x7fffc1848fcc,
authorize=<optimized out>) at epson2.c:893
#4  0x00007f12b6d01bb0 in init (be=be at entry=0x20d3f50) at dll.c:615
#5  0x00007f12b6d0255d in sane_dll_get_devices
(device_list=device_list at entry=0x7fffc1849108, local_only=local_only at entry=0)
    at dll.c:1056
#6  0x00007f12b6cf00a5 in sane_get_devices (dl=dl at entry=0x7fffc1849108,
local=local at entry=0) at dll-s.c:17
#7  0x0000000000401acb in main (argc=2, argv=0x7fffc184b268) at scanimage.c:1808

After that I have been fighting other issues with the ix500 no longer appearing
on my Fedora 18 laptop (which has two USB 3.0 ports). Not sure why ... need to
fix that before I can test again. 

I'll also try on a Fedora 17 box with USB 2.0 ports. It has a surprisingly large
number (145!) of dependencies on the sane*rpm packages, so I won't be able to
clean them.

What's the best way to run this out of /opt/sane/... without interference from
existing Fedora 17 / 18 packages?


More information about the sane-devel mailing list