[sane-devel] scanbd: Can't get the scbtn device list

Alexander Tomisch alex at tomisch.de
Sun Dec 28 20:08:07 UTC 2014


I tried to install scanbd on a Arch Linux X64 but it did not recognize 
my Scanner - output of scanbd: "Can't get the scbtn device list".

It is not my first time with scanbd and on my previous installations it 
was already working with my scanner and the scanbuttond epson backend.

I first installed scanbd from AUR (1.4.0) and then i tried the latest 
(1.4.1) from sourceforge - same problem.

Scanning with sane is working, also "through" the running scanbd-service.

Output of lsusb:

Bus 001 Device 049: ID 04b8:010c Seiko Epson Corp. GT-6700U [Perfection 640]

Output of scanbd, it runs as root for testing:

/usr/bin/scanbd -d7 -f -c /etc/scanbd/scanbd.conf

/usr/bin/scanbd: foreground
/usr/bin/scanbd: config-file: /etc/scanbd/scanbd.conf
/usr/bin/scanbd: reading config file /etc/scanbd/scanbd.conf
/usr/bin/scanbd: debug on: level: 7
/usr/bin/scanbd: dropping privs to uid root
/usr/bin/scanbd: dropping privs to gid scanner
/usr/bin/scanbd: group scanner has member:
/usr/bin/scanbd: alex
/usr/bin/scanbd: drop privileges to gid: 96
/usr/bin/scanbd: Running as effective gid 96
/usr/bin/scanbd: drop privileges to uid: 0
/usr/bin/scanbd: Running as effective uid 0
/usr/bin/scanbd: dbus_init
/usr/bin/scanbd: dbus match 
/usr/bin/scanbd: Loading /usr/lib/scanbd/scanbuttond/backends/meta.so
/usr/bin/scanbd: meta-backend: init
/usr/bin/scanbd: libusbi: initializing...
/usr/bin/scanbd: Loading /usr/lib/scanbd/scanbuttond/backends/epson.so
/usr/bin/scanbd: meta-backend: attaching backend: Epson USB
/usr/bin/scanbd: epson-backend: init
/usr/bin/scanbd: Scanning for local-only devices
/usr/bin/scanbd: Can't get the scbtn device list
/usr/bin/scanbd: device list null
/usr/bin/scanbd: start_scbtn_threads
/usr/bin/scanbd: start the threads (0)
/usr/bin/scanbd: start dbus thread
/usr/bin/scanbd: Not Primary Owner (-1)
/usr/bin/scanbd: Name Error (Connection ":1.110" is not allowed to own 
the service "de.kmux.scanbd.server" due to security policies in the 
configuration file)
/usr/bin/scanbd: udev init
/usr/bin/scanbd: get udev monitor
/usr/bin/scanbd: udev fd is non-blocking, now setting to blocking mode
/usr/bin/scanbd: start udev thread
/usr/bin/scanbd: udev thread started
^C/usr/bin/scanbd: sig_term/int_handler called with signal 2
/usr/bin/scanbd: stop_scbtn_threads
/usr/bin/scanbd: waiting ...
/usr/bin/scanbd: stop dbus thread
/usr/bin/scanbd: stop udev thread
/usr/bin/scanbd: join udev thread
/usr/bin/scanbd: cleanup device handler
/usr/bin/scanbd: close udev monitor
/usr/bin/scanbd: close udev
/usr/bin/scanbd: exiting scanbd


Any hints?


More information about the sane-devel mailing list