[sane-devel] Kodak i1210 Plus Scanner on FreeBSD 9.3 (SANE 1.0.23)

Jeffrey Mealo jeffreymealo at gmail.com
Wed Jan 29 01:48:46 UTC 2014

Hello all,

I'm trying to setup SANE 1.0.23 with my Kodak i1210 Plus (USB, ADF) on
FreeBSD 9.3.

sane-find-scanner output:

found USB scanner (vendor=0x040a [KODAK], product=0x600a [i1210 SCANNER])
at libusb:/dev/usb:/dev/ugen1.5

scanimage -L output:

No scanners were identified.

Permissions on scanner:

lrwxr-xr-x  1 root  wheel            9 Jan 28 00:43 ugen1.5 -> usb/1.5.0

My scanning environment is inside of a FreeBSD jail. I'm unsure how to
definitively eliminate permissions as the culprit. (Any ideas?)

Here's what I've tried:

In /usr/local/etc/devd/saned.conf:

notify 100 {
    match "system" "USB";
    match "subsystem" "INTERFACE";
    match "type" "ATTACH";
    match "cdev" "ugen[0-9].[0-9]";
    match "vendor" "0x0424";
    match "product" "0x2502";
    action "chown -L saned:saned /dev/$cdev && chmod -L 660 /dev/$cdev";

Added saned user to wheel (incase the above file didn't work):

pw usermod saned -G wheel

The Kodak i1210 doesn't appear to be officially supported, however, it does
have official Linux drivers from Kodak:

Any ideas where to go from here? I have no reason to believe it's a
permission issue, however, I have no reason to believe it's not as it's
still not working :-).

Thanks for reading,

If you are archiving photos:

The Kodak i1210/i1220 Plus does not mar or damage old photos (fiber, resin
coated, glossy, matte) photos like most sheetfed scanners. (I've scanned
over 200,000 photos, fed in stacks of similarly sized prints with this
unit, non were damaged). It's a good all around scanner.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20140128/620f885d/attachment.html>

More information about the sane-devel mailing list