[sane-devel] Xsane (canon MG6450)

Rolf Bensch rolf at bensch-online.de
Wed May 7 17:34:47 UTC 2014

Hi Timo,

Am 06.05.2014 18:44, schrieb Timo Tervahauta:
> Hello Rolf!
> i have tried to find my scanner as the sane-find-scanner tool tells me.
> without result, it did not find my canon.
> but insted i went to youtube and saw how too use terminal and i used
> "lsusb" command and
> did find this : Bus 003 Device 002: ID 04a9:1770 Canon, Inc.
> but still when i start the xsane image scanning program it dosent find
> my cannon scanner. (multi printer/scanner)
> -tried to uninstall all scan progs and reinstall them even here without
> result.
> -tried "xsane" command in terminal, (no device found)
> -tried install
> (git clone git://git.debian.org/sane/sane-backends.git)
> with terminal and it tells me:  Couldn't find any package by regex 'git://git.debian.org/sane'

This command is working:

$ git clone git://git.debian.org/sane/sane-backends.git
Cloning into 'sane-backends'...
remote: Counting objects: 46269, done.
remote: Compressing objects: 100% (11921/11921), done.
remote: Total 46269 (delta 34616), reused 44759 (delta 33485)
Receiving objects: 100% (46269/46269), 22.27 MiB | 1.63 MiB/s, done.
Resolving deltas: 100% (34616/34616), done.

> -vaio at vaio:~$ scanimage -V
> scanimage (sane-backends) 1.0.23; backend version 1.0.23.

You need backend version >= 1.0.24.

> -vaio at vaio:~$ sudo scanimage -L
> No scanners were identified. If you were expecting something different,
> check that the scanner is plugged in, turned on and detected by the
> sane-find-scanner tool (if appropriate). Please read the documentation
> which came with this software (README, FAQ, manpages).
> I did not understand too much from the guide here: 
> http://www.sane-project.org/README.linux
> -vaio at vaio:~$ sane-find-scanner
>   # sane-find-scanner will now attempt to detect your scanner. If the
>   # result is different from what you expected, first make sure your
>   # scanner is powered up and properly connected to your computer. ----------------------------------*check*
>   # No SCSI scanners found. If you expected something different, make sure that
>   # you have loaded a kernel SCSI driver for your SCSI adapter. -----------------------------------*understanding issue*     
> could not open USB device 0x1d6b/0x0002 at 002:001: Access denied (insufficient permissions)
> could not open USB device 0x0bda/0x5729 at 001:003: Access denied (insufficient permissions)
> could not open USB device 0x1d6b/0x0002 at 001:001: Access denied (insufficient permissions)
> could not open USB device 0x1d6b/0x0003 at 004:001: Access denied (insufficient permissions)
> could not open USB device 0x04a9/0x1770 at 003:004: Access denied (insufficient permissions)
> could not open USB device 0x1d6b/0x0002 at 003:001: Access denied (insufficient permissions)
>   # No USB scanners found. If you expected something different, make sure that
>   # you have loaded a kernel driver for your USB host controller and have setup
>   # the USB system correctly. See man sane-usb for details.------------------------------------------*setup???*
>   # Not checking for parallel port scanners.
>   # Most Scanners connected to the parallel port or other proprietary ports
>   # can't be detected by this program.
>   # You may want to run this program as root to find all devices. Once you-----------------------------*no help sudo*
>   # found the scanner devices, be sure to adjust access permissions as
>   # necessary.
> And what is this!?: 
>  *canon*
>          The canon backend  supports  the  CanoScan  300,  CanoScan  600,  and
>          CanoScan 2700F SCSI flatbed scanners. See *sane-canon(5) <http://www.sane-project.org/man/sane-canon.5.html>* for details.
>        *canon630u*
>          The  canon630u  backend supports the CanoScan 630u and 636u USB scan‐
>          ners.  See *sane-canon630u(5) <http://www.sane-project.org/man/sane-canon630u.5.html>* for details.
>        *canon_dr*
>          The canon_dr backend supports the Canon DR-Series ADF  SCSI  and  USB
>          scanners. See *sane-canon_dr(5) <http://www.sane-project.org/man/sane-canon_dr.5.html>* for details.
>        *canon_pp*
>          The  canon_pp backend supports the CanoScan FB330P, FB630P, N340P and
>          N640P parallel port scanners.  See *sane-canon_pp(5) <http://www.sane-project.org/man/sane-canon_pp.5.html>* for details.

Your scanner is supported from the pixma backend! Ignore the canon*

> I am really lost here right now. 
> i understand that i did not follow the instructions right from : 
> http://www.sane-project.org/README.linux
> but i think it's not quite a step by step instruction there.
> This terminal thing is not my favorite and i do not understand what the
> commands do either.
> found a video on how to do on youtube but it was fedora.
> What do you think i shuld do?

Follow the step by step instructions in README.linux starting here:
'Step by step install on Linux 2.6.* and 3.*, both with udev:'.
Ignore the other stuff around.

You can skip position '3.2. Localization file:'.

Maybe you need to install some development packages first. But this
depends on your Linux distribution. What Linux distribution do you have?


More information about the sane-devel mailing list