[sane-devel] HP scanjet 8200: open of device avision:libusb:001:004 failed: Operation not supported

abel deuring adeuring at gmx.net
Sun Sep 7 17:36:01 UTC 2014


a friend bought recently an HP Scanjet 8200 and tried to use it under
Ubuntu 14.04 (sane version 1.0.23). The scanner does not have any
accessories like an ADF or a transparency unit.

scanimage -L says:

device `avision:libusb:001:003' is a Hewlett-Packard ScanJet 8200
flatbed scanner

Attempts to run a simple "scanimage > /dev/null" results in the error:

scanimage: open of device avision:libusb:001:004 failed: Operation not

The stderr output from "SANE_DEBUG_AVISION=255 scanimage" is in the
attached file.

I see the same error when using self compilied binaries from GIT
revision 29abd19a8f7a0df7614484e887d8d79210687a0e.

But the following patch of the function get_accessories_info() avoids
the problem:

diff --git a/backend/avision.c b/backend/avision.c
index 31b0a58..b1094d4 100644
--- a/backend/avision.c
+++ b/backend/avision.c
@@ -3164,7 +3164,7 @@ static SANE_Status
 get_accessories_info (Avision_Scanner* s)
   Avision_Device* dev = s->hw;
-  int try = 3;
+  int try = 1;

   /* read stuff */
   struct command_read rcmd;
@@ -3238,7 +3238,7 @@ get_accessories_info (Avision_Scanner* s)
         goto RETRY;
       DBG (1, "get_accessories_info: Maximum retries attempted, ADF
+      return SANE_STATUS_GOOD;

(The first change isn't important to avoid the problem but makes the
"start phase" of the scan a bit faster.)

I would not claim that this change is reasonable for inclusion into the
Sane repositories: I did not read the file avision.c very carefully, I
don't have any technical docs for the HP8200 available (neither for any
other of the many scanners supported by the avision backend...) and
can't hence say how this change could affect other scanners supported by
the backend, or even an HP8200 having an ADF installed.

This problem seems to be a bit older. I found these bug reprots for
Ubuntu and Suse:


Myself and the owner of the scanner are able to test other workarounds
or real fixes -- but the response time will be a bit slow: I'll need to
visit the owner in order to try anything...

-------------- next part --------------
A non-text attachment was scrubbed...
Name: hp8200.log.gz
Type: application/x-gzip
Size: 4345 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20140907/064a1cc7/attachment.bin>

More information about the sane-devel mailing list