[sane-devel] Scanner failure when connected via USB3

Jorge Fábregas jorge.fabregas at gmail.com
Sat Sep 13 00:34:46 UTC 2014

On 09/11/2014 05:19 AM, Mike Cloaked wrote:
> This would seem to indicate that there is some kind of bug in the sane
> packages. I have tried in the past to find out how to diagnose this issue
> but I don't know where to begin to get logs that might help in finding
> where the problem lies.

Hi Mike,

I have the same scanner & had exactly the same issue when I recently
replaced my desktop computer.  I spent quite some time trying to figure
out what was the cause & indeed there are plenty of people with this
problem!  The bug seems to be within the xhci_hcd kernel module.

The thing is that my computer has some USB 2 ports on the back and the
scanner still didn't work there.  What surprised me was that dmesg still
showed "xhci_hcd" as being used by those USB 2 ports.  So, it seems
that, on my computer,  even though I'm connecting the scanner to a USB 2
port on the back, it is still been routed internally to the USB3 host

I then went to my BIOS and found an option , under the USB section,
called "USB Debug Support", that said:

"Select whether to enable or disable the USB port 6 debug capability.
Note: If the function is enabled, the port 6 will work as an USB 2.0 port".

 I enabled it and placed my scanner on that particular port and bingo
(dmesg showed ehci-pci as being used) & the scanner worked perfectly
fine.  Of course, this is a workaround (not a fix) but I'm happy to use
it in the meantime.  This is a Lenovo workstation & I'm lucky to have
that option (to enable USB 2 for just one particular port without
affecting the rest of my USB 3 ports).

This thread pointed me to the right direction:


Try to see if there's such an option on your BIOS.


p.d. I'm using Fedora 20

More information about the sane-devel mailing list