[sane-devel] Canon Support for Scanning -- Not!

Alan McConnell alan at his.com
Tue Apr 7 13:38:56 UTC 2015

I suppose most experts here will find me naive, but I think you
should be aware of reaction I received from Canon "Support", after
sending them an E-mail yesterday.  I received an E-mail from them
this morning which I reproduce here; note that it contains the
text of the E-mail I sent to them yesterday.

Dear Alan McConnell:

Thank you for contacting Canon product support.
Scanning is not supported using Linux. 


Technical Support Representative

Special Note: Certain issues are very difficult to resolve via
email.  If you would prefer to speak to a technician for
additional assistance, you may call our special toll-free number
for email customers with unresolved issues by dialing
1-866-261-9362, Monday - Friday 8:00 a.m. to 8:00 p.m. ET
(excluding holidays).  If you prefer to continue to communicate
via email, reply to this message and we will respond as quickly
as possible.

Email is not a secure form of communication. Please do not send
us your credit card number or other personal or account
information via email.

--Original Message--
From: alan at his.com
Date: 4/6/2015 6:34:27 PM
To: lasercopier at cits.canon.com
Subject: Response from Canon - imageCLASS Series > imageCLASS MF4770n

Email Support Form Message

Product Type: imageCLASS Series
Product Name: imageCLASS MF4770n
First Name: Alan
Last Name: McConnell
Address 1:
Zip/Postal Code:  
Country: USA
Email Address: alan at his.com
Email Verification: alan at his.com
Product Serial Number:  QZJ8298
Date of Purchase: //
Connection: USB
Operating Systems:
Problem Type: Setup

Please provide the exact problem description 
(Please do not enter any credit card details or other financial information):
I have a MF4770n, bought two weeks ago.  It prints fine.  Now
I need to get its scan function to work.

I am running Linux, Debian Wheezy.  I have libsane backends
1.0.24.  When I run sane-find-scanner, it returns
    found USB scanner (vendor=0x04a9, product=0x2774) at 
However, 'scanimage -L returns: "no scanners were identified

When I run   man sane-pixma  I get a list of the models
that work with this backend.  Among them is imageCLASS
MF4770n .

I hope you can tell me what further to do, in order to
use this MF4770n as a scanner. 

Thank you in advance.


Alan McConnell :  http://globaltap.com/~alan/
     "St Francis! preaching to the birds!  if he had really
     wanted to save birds, he'd have preached to the cats."

More information about the sane-devel mailing list