[sane-devel] Some weirdness with a Canon LiDE 220

Scott Alfter scott at alfter.us
Tue Dec 15 21:29:24 UTC 2015

I've had this scanner working with prerelease code and the final 1.0.25
release for several months, but when I tried scanning something in the
other day, it refused to start up.  I normally use xsane to scan
documents; after hitting the "acquire preview" button, the scanner
carriage makes a short moving sound, and then a dialog pops up:

Failed to start scanner: Invalid argument

The only thing that's changed recently is the underlying hardware, of
which I've upgraded the processor, motherboard, and memory.  I've gone
from a Core 2 Quad Q6600 to a Core i5 4690K (which I haven't
overclocked).  The new motherboard supports USB 3.0 as well as 2.0; I've
tried both types and seen no difference in behavior.  Since I'm running
Gentoo Linux, I had it recompile the whole system for the new processor
(-march=core-avx2), but I've also tried rebuilding with the older config
(-march=core2), and that made no difference.

I wouldn't think a faster processor would break SANE.  I've tried
getting some more useful output from it to include, but scanimage -v
isn't any more verbose than scanimage without -v (or xsane) and only
produces this message:

scanimage: sane_start: Invalid argument

On a lark, I then checked to see if scanimage -vv might be more verbose:

$ scanimage -vvd genesys:libusb:003:007 --format pnm foo.pnm
scanimage: scanning image of size 636x878 pixels at 8 bits/pixel
scanimage: acquiring gray frame
scanimage: min/max graylevel value = 0/254
scanimage: read 558408 bytes in total
Closing device
Calling sane_exit
scanimage: finished

foo.pnm has valid PGM image data.  Including --resolution and --mode
options works as expected.

I then tried removing one v, and then the other, and different
resolution and bit-depth settings, and it still worked.  I then tried
going back to xsane...still won't work.  Back to the
command-line...scanimage still works.

I then fired up gscan2pdf (maybe I should remember to use this more
often).  With its default settings, it appears to work properly.

When I started writing this up, I was about to blame the sane-backends
package for breakage, but it's now looking more like the problem is with
xsane...but the only change within the past year with the xsane ebuild
is a keyword change on a different architecture.  Upstream source
doesn't appear to have changed since May 2013.  What would explain this
breakage?  Is it something that can be fixed or worked around, or should
I start looking for something else to scan photos?  (I probably
should've been using gscan2pdf for documents...need to familiarize
myself with that a bit better.)

Scott Alfter
scott at alfter.us

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 648 bytes
Desc: OpenPGP digital signature
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20151215/48db28a2/attachment.sig>

More information about the sane-devel mailing list